6in4: remove 6in4 tunnel delete workaround (FS#3690)
authorHans Dedecker <dedeckeh@gmail.com>
Sat, 30 Oct 2021 19:08:38 +0000 (21:08 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Sat, 30 Oct 2021 19:15:18 +0000 (21:15 +0200)
Remove 6in4 tunnel delete workaround as the real issue is
now solved in netifd
(https://git.openwrt.org/?p=project/netifd.git;a=commit;h=8f82742ca4f47f459284f3a07323d04da72ea5f6)

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
package/network/ipv6/6in4/Makefile
package/network/ipv6/6in4/files/6in4.sh

index 331295ba7ada456c5b6768b763b765424b0e79d5..edbb7d71a01af82c2284e879fa66503786b8054e 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
-PKG_RELEASE:=27
+PKG_RELEASE:=28
 PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
index d0904952fdf316c7106bf9146160d16971e62619..5b5c7b36af9cd18732a6958ec28d21dc37885137 100755 (executable)
@@ -138,8 +138,6 @@ proto_6in4_setup() {
 
 proto_6in4_teardown() {
        local cfg="$1"
-       local link="6in4-$cfg"
-       ip link del $link
 }
 
 proto_6in4_init_config() {