realtek: build factory images for all DGS-1210 models
authorMarkus Stockhausen <markus.stockhausen@gmx.de>
Wed, 6 Jul 2022 11:41:51 +0000 (13:41 +0200)
committerSander Vanheule <sander@svanheule.net>
Fri, 8 Jul 2022 18:15:22 +0000 (20:15 +0200)
Currently we build factory images only for DGS-1210-28 model. Relax
that constraint and take care about all models. Tested on DGS-1210-20
and should work on other models too because of common flash layout.

Tested-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Signed-off-by: Markus Stockhausen <markus.stockhausen@gmx.de>
target/linux/realtek/image/rtl838x.mk

index dc181821105f19b0ebbbd6b1c3a9f09d32cc6ac1..8eac72b3ef8c3e968b32b0d89b48949bf7a41218 100644 (file)
@@ -17,6 +17,13 @@ define Device/d-link_dgs-1210
   DEVICE_VENDOR := D-Link
   DLINK_KERNEL_PART_SIZE := 1572864
   KERNEL := kernel-bin | append-dtb | gzip | uImage gzip | dlink-cameo
+  CAMEO_KERNEL_PART := 2
+  CAMEO_ROOTFS_PART := 3
+  CAMEO_CUSTOMER_SIGNATURE := 2
+  CAMEO_BOARD_VERSION := 32
+  IMAGES += factory_image1.bin
+  IMAGE/factory_image1.bin := append-kernel | pad-to 64k | \
+       append-rootfs | pad-rootfs | pad-to 16 | check-size | dlink-headers
 endef
 
 define Device/d-link_dgs-1210-10p
@@ -41,13 +48,6 @@ TARGET_DEVICES += d-link_dgs-1210-20
 define Device/d-link_dgs-1210-28
   $(Device/d-link_dgs-1210)
   DEVICE_MODEL := DGS-1210-28
-  CAMEO_KERNEL_PART := 2
-  CAMEO_ROOTFS_PART := 3
-  CAMEO_CUSTOMER_SIGNATURE := 2
-  CAMEO_BOARD_VERSION := 32
-  IMAGES += factory_image1.bin
-  IMAGE/factory_image1.bin := append-kernel | pad-to 64k | \
-        append-rootfs | pad-rootfs | pad-to 16 | check-size | dlink-headers
 endef
 TARGET_DEVICES += d-link_dgs-1210-28