build: suppress cmake warnings about unused vars
authorTjalling Hattink <t.hattink@fugro.com>
Tue, 26 Sep 2023 13:10:52 +0000 (15:10 +0200)
committerPaul Spooren <mail@aparcar.org>
Wed, 4 Oct 2023 10:28:45 +0000 (12:28 +0200)
When cmake is invoked to build a package it usually reports a warning
about unused variables passed to it. This is caused by openwrt passing
all supported variables to cmake, even if they are not all required by
the package being compiled.

To reduce clutter when compiling such packages these warnings are now
suppressed.

Approved-by: Rosen Penev <rosenp@gmail.com>
Reviewed-by: Robert Marko <robimarko@gmail.com>
Signed-off-by: Tjalling Hattink <t.hattink@fugro.com>
include/cmake.mk

index 9b169b069346f292c6ce9c5be83174e0c420a130..95870ffdb0f7058c3ca8599831278ae2a563df1c 100644 (file)
@@ -89,6 +89,7 @@ define Build/Configure/Default
                CXXFLAGS="$(TARGET_CXXFLAGS) $(EXTRA_CXXFLAGS)" \
                LDFLAGS="$(TARGET_LDFLAGS) $(EXTRA_LDFLAGS)" \
                cmake \
+                       --no-warn-unused-cli \
                        -DCMAKE_SYSTEM_NAME=Linux \
                        -DCMAKE_SYSTEM_VERSION=1 \
                        -DCMAKE_SYSTEM_PROCESSOR=$(ARCH) \
@@ -141,6 +142,7 @@ define Host/Configure/Default
                CXXFLAGS="$(HOST_CFLAGS)" \
                LDFLAGS="$(HOST_LDFLAGS)" \
                cmake \
+                       --no-warn-unused-cli \
                        -DCMAKE_BUILD_TYPE=Release \
                        -DCMAKE_C_COMPILER_LAUNCHER="$(CMAKE_C_COMPILER_LAUNCHER)" \
                        -DCMAKE_C_COMPILER="$(CMAKE_HOST_C_COMPILER)" \