kernel: kmod-ata-ahci-platform: enable support for RK35xx
authorMarius Durbaca <mariusd84@gmail.com>
Wed, 28 Feb 2024 08:37:44 +0000 (08:37 +0000)
committerNick Hainke <vincent@systemli.org>
Sat, 23 Mar 2024 06:55:43 +0000 (07:55 +0100)
enable support for RK35xx in kmod-ata-ahci-platform kernel module

Suggested-by: Tianling Shen <cnsztl@immortalwrt.org>
Signed-off-by: Marius Durbaca <mariusd84@gmail.com>
package/kernel/linux/modules/block.mk

index 49a1b6fce1155f4d4172ccdf90bd48fdbca33920..4f3a6e085ffb2296d3806fa7bb42a1b909a3ed4c 100644 (file)
@@ -65,7 +65,7 @@ define KernelPackage/ata-ahci-platform
     $(LINUX_DIR)/drivers/ata/ahci_platform.ko \
     $(LINUX_DIR)/drivers/ata/libahci_platform.ko
   AUTOLOAD:=$(call AutoLoad,40,libahci libahci_platform ahci_platform,1)
-  $(call AddDepends/ata,@TARGET_ipq806x||TARGET_layerscape||TARGET_sunxi)
+  $(call AddDepends/ata,@TARGET_ipq806x||TARGET_layerscape||TARGET_rockchip||TARGET_sunxi)
 endef
 
 define KernelPackage/ata-ahci-platform/description