xdp-tools: disable stack protector for BPF programs
authorStijn Tintel <stijn@linux-ipv6.be>
Fri, 28 Jul 2023 19:40:34 +0000 (22:40 +0300)
committerStijn Tintel <stijn@linux-ipv6.be>
Thu, 3 Aug 2023 14:39:39 +0000 (17:39 +0300)
When building xdp-tools with CONFIG_USE_LLVM_HOST=y, on a host that
enabled stack protector by default in Clang, compilation fails with the
following error:

    CLANG    xdp-dispatcher.o
clang-16: error: ignoring '-fstack-protector-strong' option as it is not currently supported for target 'bpfeb' [-Werror,-Woption-ignored]

Add -fno-stack-protector to BPF_CFLAGS to fix this.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
package/network/utils/xdp-tools/Makefile

index 3cc7980cf60b670ac904a2404db8a621b63ea9a6..dba775e4ea1420de393f0c5aef2bfd29f6577015 100644 (file)
@@ -94,7 +94,7 @@ MAKE_VARS += \
 
 define Build/Configure
        $(call Build/Configure/Default)
-       echo "BPF_CFLAGS += -I$(BPF_HEADERS_DIR)/tools/lib" >> $(PKG_BUILD_DIR)/config.mk
+       echo "BPF_CFLAGS += -I$(BPF_HEADERS_DIR)/tools/lib -fno-stack-protector" >> $(PKG_BUILD_DIR)/config.mk
 endef
 
 define Build/InstallDev