tools: b43-tools: fix compilation with GCC14
authorRobert Marko <robimarko@gmail.com>
Fri, 29 Mar 2024 17:57:03 +0000 (18:57 +0100)
committerRobert Marko <robimarko@gmail.com>
Sat, 30 Mar 2024 09:42:47 +0000 (10:42 +0100)
GCC14 no longer treats integer types and pointer types as equivalent in
assignments (including implied assignments of function arguments and return
values), and instead fails the compilation with a type error.

So, as a workaround lets disable the newly introduced error
-Werror=int-conversion and just make it print a warning to enable compiling
with GCC14 as Fedora 40 now defaults to it.

Signed-off-by: Robert Marko <robimarko@gmail.com>
tools/b43-tools/Makefile

index d3f6e80b5245ffd4d3ead33f2eca5d92dae90198..ed8030e9c5d7de1e239551df2b79c8462247774e 100644 (file)
@@ -23,7 +23,7 @@ define Host/Compile
                $(HOST_MAKE_FLAGS) \
                $(1) QUIET_SPARSE=:
        +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR)/assembler \
-               CFLAGS="$(HOST_CFLAGS) -include endian.h" \
+               CFLAGS="$(HOST_CFLAGS) -include endian.h -Wno-error=int-conversion" \
                $(HOST_MAKE_FLAGS) \
                LDFLAGS= \
                $(1) QUIET_SPARSE=: