uqmi: fix PIN_STATUS_FAILED error with MC7455 WCDMA/LTE modem
authorDaniel Golle <daniel@makrotopia.org>
Wed, 20 Feb 2019 14:12:44 +0000 (15:12 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 20 Feb 2019 14:16:24 +0000 (15:16 +0100)
Apparently this modem replies differently to attempted --get-pin-status
which makes the script fail if a pincode is set. Fix this.

Manufacturer: Sierra Wireless, Incorporated
Model: MC7455
Revision: SWI9X30C_02.24.05.06 r7040 CARMD-EV-FRMWR2 2017/05/19 06:23:09

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/network/utils/uqmi/Makefile
package/network/utils/uqmi/files/lib/netifd/proto/qmi.sh

index b2f3474400364cf25fdcf5d6b9db8cf67f51f5cd..8eaf0bff3f9aad6690034b9ffa215902d89533ef 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uqmi
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/uqmi.git
index 9b2f69f009f467e204dcab6f6c8557398057179f..1da98db5ac7b35d39143b8393bff8b1bdcf06d59 100755 (executable)
@@ -83,7 +83,7 @@ proto_qmi_setup() {
                fi
        done
 
-       if uqmi -s -d "$device" --get-pin-status | grep '"Not supported"' > /dev/null; then
+       if uqmi -s -d "$device" --get-pin-status | grep '"Not supported"\|"Invalid QMI command"' > /dev/null; then
                [ -n "$pincode" ] && {
                        uqmi -s -d "$device" --verify-pin1 "$pincode" > /dev/null || uqmi -s -d "$device" --uim-verify-pin1 "$pincode" > /dev/null || {
                                echo "Unable to verify PIN"