Revert "tools/mkimage: update to v2024.04"
authorNick Hainke <vincent@systemli.org>
Sat, 6 Apr 2024 12:49:54 +0000 (14:49 +0200)
committerNick Hainke <vincent@systemli.org>
Sat, 6 Apr 2024 12:52:06 +0000 (14:52 +0200)
This reverts commit 8d934c11968de49ad17bc62366a88230e47b4f56.

The update seems to be causing issues that need to be further
explored [0]. Let's revert it.

[0] - https://github.com/openwrt/openwrt/pull/15078

Signed-off-by: Nick Hainke <vincent@systemli.org>
tools/mkimage/Makefile
tools/mkimage/patches/030-allow-to-use-different-magic.patch
tools/mkimage/patches/095-tools-disable-TOOLS_FIT_FULL_CHECK.patch

index 6d2cc5f7643846dc9b4f11b71cc8d1c11d085b05..ae744f9bf3d66ce4d502da5705a38a07708de39d 100644 (file)
@@ -7,14 +7,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mkimage
-PKG_VERSION:=2024.04
+PKG_VERSION:=2024.01
 
 PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
        https://mirror.cyberbits.eu/u-boot \
        https://ftp.denx.de/pub/u-boot \
        ftp://ftp.denx.de/pub/u-boot
-PKG_HASH:=18a853fe39fad7ad03a90cc2d4275aeaed6da69735defac3492b80508843dd4a
+PKG_HASH:=b99611f1ed237bf3541bdc8434b68c96a6e05967061f992443cb30aabebef5b3
 
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
 
index bcbdc4d6cd12e7b7f4ff7a48a731825d90d43b81..f2f57965f604fe77e52d440172d56529b9b1706d 100644 (file)
@@ -24,7 +24,7 @@ This patch makes it possible to set a custom image magic.
                "          -a ==> set load address to 'addr' (hex)\n"
                "          -e ==> set entry point to 'ep' (hex)\n"
                "          -n ==> set image name to 'name'\n"
-@@ -160,7 +162,7 @@ static int add_content(int type, const c
+@@ -159,7 +161,7 @@ static int add_content(int type, const c
  }
  
  static const char optstring[] =
@@ -33,7 +33,7 @@ This patch makes it possible to set a custom image magic.
  
  static const struct option longopts[] = {
        { "load-address", required_argument, NULL, 'a' },
-@@ -303,6 +305,14 @@ static void process_args(int argc, char
+@@ -302,6 +304,14 @@ static void process_args(int argc, char
                case 'l':
                        params.lflag = 1;
                        break;
index ed6824b11a83780089ab2a7a95ff6e1a7d3102f6..f2e3b9b053021a510ca21c9d91f076663539c877 100644 (file)
@@ -14,7 +14,7 @@ https://github.com/u-boot/u-boot/commit/3f04db891a353f4b127ed57279279f851c6b4917
 
 --- a/tools/Kconfig
 +++ b/tools/Kconfig
-@@ -36,7 +36,7 @@ config TOOLS_FIT
+@@ -31,7 +31,7 @@ config TOOLS_FIT
          Enable FIT support in the tools builds.
  
  config TOOLS_FIT_FULL_CHECK