Revert "prereq-build: add Python 3.12 support"
authorPaul Spooren <mail@aparcar.org>
Mon, 13 Nov 2023 22:32:12 +0000 (23:32 +0100)
committerPaul Spooren <mail@aparcar.org>
Mon, 13 Nov 2023 22:33:40 +0000 (23:33 +0100)
This reverts commit 7ceb76ca3a37ba6b722df39ba0838909fa7cf7b4.

Python 3.12 removes the distutils package and is therefore not
compatible. We have to check downstream what relies on distutils before
adding actual support for Python 3.12. Sorry for the noise.

With this in-place, the macOS CI job fails and turns things red, revert
for now.

Signed-off-by: Paul Spooren <mail@aparcar.org>
include/prereq-build.mk

index 2378f5ad90c961472f8751f2d116f9978d976b7d..49340ce3e441ccbaa1833d6eb38d8abd450f627e 100644 (file)
@@ -182,7 +182,6 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
        perl --version | grep "perl.*v5"))
 
 $(eval $(call SetupHostCommand,python,Please install Python >= 3.7, \
-       python3.12 -V 2>&1 | grep 'Python 3', \
        python3.11 -V 2>&1 | grep 'Python 3', \
        python3.10 -V 2>&1 | grep 'Python 3', \
        python3.9 -V 2>&1 | grep 'Python 3', \
@@ -191,7 +190,6 @@ $(eval $(call SetupHostCommand,python,Please install Python >= 3.7, \
        python3 -V 2>&1 | grep -E 'Python 3\.([7-9]|[0-9][0-9])\.?'))
 
 $(eval $(call SetupHostCommand,python3,Please install Python >= 3.7, \
-       python3.12 -V 2>&1 | grep 'Python 3', \
        python3.11 -V 2>&1 | grep 'Python 3', \
        python3.10 -V 2>&1 | grep 'Python 3', \
        python3.9 -V 2>&1 | grep 'Python 3', \