hostapd: add config symbol to enable DPP
authorStijn Tintel <stijn@linux-ipv6.be>
Tue, 27 Sep 2022 08:34:26 +0000 (11:34 +0300)
committerStijn Tintel <stijn@linux-ipv6.be>
Thu, 15 Jun 2023 09:24:29 +0000 (12:24 +0300)
Device Provisioning Protocol (also known as Wi-Fi Easy Connect) provides
a simplified, standardized way of onboarding device through use of QR
codes, bluetooth, NFC or downloading device information from the cloud.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
package/network/services/hostapd/Config.in
package/network/services/hostapd/Makefile

index 87ad7e093e7da0629e044721f29e43cc4c76b780..46acb1f97febf75f107d8e957a2893281ea067ac 100644 (file)
@@ -82,6 +82,21 @@ config DRIVER_11AX_SUPPORT
        default n
        select WPA_MBO_SUPPORT
 
+config WPA_DPP_SUPPORT
+       bool "Device Provisioning Protocol (DPP)"
+       default n
+       depends on PACKAGE_wpa-supplicant-openssl || \
+                  PACKAGE_wpa-supplicant-mesh-openssl || \
+                  PACKAGE_wpad-basic-openssl || \
+                  PACKAGE_wpad-mesh-openssl || \
+                  PACKAGE_wpad-openssl
+       help
+         Device Provisioning Protocol (DPP) version 1 and 2, also known as
+         Wi-Fi Easy Connect. Version 3 is excluded as it's considered
+         experimental and still changing.
+
+         Crypto required for DPP is only implemented for OpenSSL.
+
 config WPA_ENABLE_WEP
        bool "Enable support for unsecure and obsolete WEP"
        help
index dc2967048981246bd04d358d84ec2a857a86cdc6..de8eb427303e5de553f4230dc27a482c011d207b 100644 (file)
@@ -86,6 +86,7 @@ DRIVER_MAKEOPTS= \
        CONFIG_DRIVER_NL80211=$(CONFIG_PACKAGE_kmod-cfg80211) \
        CONFIG_IEEE80211AC=$(HOSTAPD_IEEE80211AC) \
        CONFIG_IEEE80211AX=$(HOSTAPD_IEEE80211AX) \
+       CONFIG_DPP=$(CONFIG_WPA_DPP_SUPPORT) \
        CONFIG_MBO=$(CONFIG_WPA_MBO_SUPPORT)
 
 ifeq ($(SSL_VARIANT),openssl)