wireguard-tools: allow compiling with MIPS16 instructions
authorRui Salvaterra <rsalvaterra@gmail.com>
Fri, 24 Jul 2020 08:02:55 +0000 (09:02 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Sat, 1 Aug 2020 13:54:39 +0000 (14:54 +0100)
The wg utility compiles and runs without issues in MIPS16 mode, despite setting
PKG_USE_MIPS16:=0 in the makefile. Let's remove this, allowing for a substantial
size reduction of the wg executable. Since wg is a just a configuration utility,
it shouldn't be performance-critical, as the crypto heavy-lifting is done on the
kernel side.

wg sizes for both modes:

MIPS32: 64309 bytes
MIPS16: 42501 bytes

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
package/network/utils/wireguard-tools/Makefile

index 3232060bd1def785fe3cb31302dfafac88e4da76..2137a8b4a1aa7a1e877a6b06ce2160007cdec1b9 100644 (file)
@@ -22,7 +22,6 @@ PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=COPYING
 
 PKG_BUILD_PARALLEL:=1
-PKG_USE_MIPS16:=0
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/package-defaults.mk