Revert "build: remove harmful -nopad option from mksquashfs"
authorJonas Gorski <jonas.gorski@gmail.com>
Fri, 6 Sep 2019 12:55:36 +0000 (14:55 +0200)
committerJonas Gorski <jonas.gorski@gmail.com>
Sat, 7 Sep 2019 12:45:32 +0000 (14:45 +0200)
This reverts commit 1c0290c5cc6258c48b8ba46b4f9c85a21de4f875.

Dropping the nopad can make the padding overflow into the next erase
block on devices using a non-aligned rootfs start. This breaks the jffs2
overlay partition with the following messages:

[   30.343877] jffs2_scan_eraseblock(): End of filesystem marker found at 0x10000
[   30.376512] jffs2: Cowardly refusing to erase blocks on filesystem with no valid JFFS2 nodes
[   30.385253] jffs2: empty_blocks 196, bad_blocks 0, c->nr_blocks 197

Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
include/image.mk

index 599adfaa1072133670139efdf110172c45d46803..5d54bc7947e692dacd7b4e4e2e845b0e824bfc30 100644 (file)
@@ -240,7 +240,7 @@ $(eval $(foreach S,$(NAND_BLOCKSIZE),$(call Image/mkfs/jffs2-nand/template,$(S))
 
 define Image/mkfs/squashfs
        $(STAGING_DIR_HOST)/bin/mksquashfs4 $(call mkfs_target_dir,$(1)) $@ \
-               -noappend -root-owned \
+               -nopad -noappend -root-owned \
                -comp $(SQUASHFSCOMP) $(SQUASHFSOPT) \
                -processors 1
 endef