Revert "uhttpd: disable concurrent requests by default"
authorJo-Philipp Wich <jo@mein.io>
Tue, 23 Apr 2019 06:12:49 +0000 (08:12 +0200)
committerJo-Philipp Wich <jo@mein.io>
Tue, 23 Apr 2019 06:15:46 +0000 (08:15 +0200)
This reverts commit c6aa9ff38870a30dbe6da17e4edad6039fe10ddf.

Further testing has revealed that we will need to allow concurrent
requests after all, especially for situations where CGI processes
initiate further HTTP requests to the local host.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/network/services/uhttpd/Makefile
package/network/services/uhttpd/files/uhttpd.config

index 29f1c89f127820dbf3efddee1b81927a88a42d02..2a6fa3bbb061c56a4ed8197034ccd976734d24d5 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/uhttpd.git
index 8b7d84c20662e94e244c5103744ec77a7691fe7c..a3deb9cf04356fbd84396fb583b81158714db266 100644 (file)
@@ -24,7 +24,7 @@ config uhttpd main
        # If this number is exceeded, further requests are
        # queued until the number of running requests drops
        # below the limit again.
-       option max_requests 1
+       option max_requests 3
 
        # Maximum number of concurrent connections.
        # If this number is exceeded, further TCP connection