base-files: make including distfeeds.conf optional
authorJonas Gorski <jonas.gorski@gmail.com>
Wed, 13 Dec 2017 13:41:28 +0000 (14:41 +0100)
committerJonas Gorski <jonas.gorski@gmail.com>
Wed, 13 Dec 2017 13:59:07 +0000 (14:59 +0100)
To not clutter the system when building an opkg free image, generate the
distfeeds.conf only if CLEAN_IPKG is unset.

Since opkg is now a shared package, we can't rely on PACKAGE_opkg, but
since opkg is not reasonably usable without the status information, we
can tie the distfeeds.conf to it.

Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
package/base-files/Makefile

index 2cf76b1b7caf45e0cdea05ef17a616fefb4fcb87..728d787e092a814c97b36636c5153829a56f5062 100644 (file)
@@ -23,6 +23,7 @@ PKG_LICENSE:=GPL-2.0
 PKG_CONFIG_DEPENDS += \
        CONFIG_SIGNED_PACKAGES CONFIG_TARGET_INIT_PATH CONFIG_TARGET_PREINIT_DISABLE_FAILSAFE \
        CONFIG_NAND_SUPPORT \
+       CONFIG_CLEAN_IPKG \
        CONFIG_PER_FEED_REPO \
        CONFIG_PER_FEED_REPO_ADD_DISABLED \
        CONFIG_PER_FEED_REPO_ADD_COMMENTED \
@@ -190,9 +191,10 @@ define Package/base-files/install
                echo -e "# Build configuration for board $(BOARD)/$(SUBTARGET)/$(PROFILE)\n" >$(1)/etc/build.config; \
                cat $(BIN_DIR)/config.seed >>$(1)/etc/build.config)
 
-       mkdir -p $(1)/etc/opkg
-       $(call FeedSourcesAppend,$(1)/etc/opkg/distfeeds.conf)
-       $(VERSION_SED) $(1)/etc/opkg/distfeeds.conf
+       $(if $(CONFIG_CLEAN_IPKG),, \
+               mkdir -p $(1)/etc/opkg; \
+               $(call FeedSourcesAppend,$(1)/etc/opkg/distfeeds.conf); \
+               $(VERSION_SED) $(1)/etc/opkg/distfeeds.conf)
 endef
 
 ifneq ($(DUMP),1)