rpcd: add direct dependency on libjson-c
authorJo-Philipp Wich <jo@mein.io>
Fri, 21 Jun 2019 15:41:28 +0000 (17:41 +0200)
committerJo-Philipp Wich <jo@mein.io>
Fri, 21 Jun 2019 15:43:17 +0000 (17:43 +0200)
The OpenWrt buildroot ABI version rebuild tracker does not handle
transient dependencies, therefor add all libraries linked by rpcd
as direct dependencies to the corresponding binary package definition.

This ensures that rpcd is automatically rebuilt and relinked if any
of these libraries has its ABI_VERSION updated in the future.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/system/rpcd/Makefile

index 00598917fd5bbfb705ebab886518f1fa29012dd1..11fe254d6f0987840b4c3ff4edf326113f12d9b7 100644 (file)
@@ -39,7 +39,7 @@ endef
 
 define Package/rpcd
   $(Package/rpcd/default)
-  DEPENDS+= +libuci +libblobmsg-json
+  DEPENDS+= +libuci +libblobmsg-json +libjson-c
 endef
 
 define Package/rpcd/description