kernel: bump 4.19 to 4.19.75
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 24 Sep 2019 09:05:57 +0000 (11:05 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 24 Sep 2019 10:52:05 +0000 (12:52 +0200)
Refreshed all patches.

Fixes:
- CVE-2019-14814
- CVE-2019-14815
- CVE-2019-14816
- CVE-2019-14821

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/ath79/patches-4.19/910-unaligned_access_hacks.patch
target/linux/generic/backport-4.19/343-netfilter-nft_flow_offload-handle-netdevice-events-f.patch
target/linux/generic/backport-4.19/370-netfilter-nf_flow_table-fix-offloaded-connection-tim.patch
target/linux/generic/hack-4.19/661-use_fq_codel_by_default.patch

index c87feab49b8ca9f5ec78ec5306ec08f42cfdd44b..5848590e8295b68d60f647a6f487ceb6b945c774 100644 (file)
@@ -8,11 +8,11 @@ endif
 
 LINUX_VERSION-4.9 = .194
 LINUX_VERSION-4.14 = .146
-LINUX_VERSION-4.19 = .74
+LINUX_VERSION-4.19 = .75
 
 LINUX_KERNEL_HASH-4.9.194 = d5f4bb7584e461f1faa9a3f94c2ad292246fe692b0e992e072dac255f806c2e3
 LINUX_KERNEL_HASH-4.14.146 = a3c54b887ea3e679382bd4c0536e6a281b071dab2258bd3ee8af75baef2023f5
-LINUX_KERNEL_HASH-4.19.74 = 495c2fead329c2c6b17950faa07ad7406e5aa93560e5e58de93a71197579ee82
+LINUX_KERNEL_HASH-4.19.75 = dd5e7147e1e4501560fba5beb86dae6bf6ba843518ab3d4cad283de77b651b78
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index bb7f847e1b150357c5e1a6ca2b5cac7a654e2bcf..43c4932f1f36730eb610aa2eaf3d035c8a9b11d5 100644 (file)
   */
 --- a/net/ipv6/datagram.c
 +++ b/net/ipv6/datagram.c
-@@ -478,7 +478,7 @@ int ipv6_recv_error(struct sock *sk, str
+@@ -480,7 +480,7 @@ int ipv6_recv_error(struct sock *sk, str
                                ipv6_iface_scope_id(&sin->sin6_addr,
                                                    IP6CB(skb)->iif);
                } else {
                                               &sin->sin6_addr);
                        sin->sin6_scope_id = 0;
                }
-@@ -828,12 +828,12 @@ int ip6_datagram_send_ctl(struct net *ne
+@@ -830,12 +830,12 @@ int ip6_datagram_send_ctl(struct net *ne
                        }
  
                        if (fl6->flowlabel&IPV6_FLOWINFO_MASK) {
index fc668dca10e419bb460db80f59a81a922aafd361..3a9e21f58043344c81ad5aa916ee08aee080e020 100644 (file)
@@ -48,7 +48,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  MODULE_AUTHOR("Pablo Neira Ayuso <pablo@netfilter.org>");
 --- a/net/netfilter/nft_flow_offload.c
 +++ b/net/netfilter/nft_flow_offload.c
-@@ -211,47 +211,14 @@ static struct nft_expr_type nft_flow_off
+@@ -217,47 +217,14 @@ static struct nft_expr_type nft_flow_off
        .owner          = THIS_MODULE,
  };
  
index 07ef724094d8076ef40916af3ec73b8c8259abac..64eda532957dc98960327ca445b787f916847e58 100644 (file)
@@ -84,7 +84,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        }
  
 +      nf_ct_offload_timeout(flow);
-       flow->timeout = (u32)jiffies;
+       flow->timeout = (u32)jiffies + NF_FLOW_TIMEOUT;
        return 0;
  }
 @@ -316,6 +335,8 @@ static int nf_flow_offload_gc_step(struc
index fc0761c3c0ef3cbde87481001abc24db19066fe6..d147c0d74307cc41ffd4d724a3d3bbc7e190c1be 100644 (file)
@@ -83,7 +83,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  EXPORT_SYMBOL(default_qdisc_ops);
  
  /* Main transmission queue. */
-@@ -1009,7 +1009,7 @@ static void attach_one_default_qdisc(str
+@@ -1013,7 +1013,7 @@ static void attach_one_default_qdisc(str
                                     void *_unused)
  {
        struct Qdisc *qdisc;