build: fix checks for GCC11
authorPetr Štetiar <ynezz@true.cz>
Mon, 1 Mar 2021 12:29:19 +0000 (13:29 +0100)
committerPetr Štetiar <ynezz@true.cz>
Wed, 3 Mar 2021 21:51:39 +0000 (22:51 +0100)
Fedora 34 already uses GCC11.

Reported-by: Marcin Juszkiewicz <marcin-openwrt@juszkiewicz.com.pl>
Signed-off-by: Petr Štetiar <ynezz@true.cz>
include/prereq-build.mk

index 8a6c4bb4684013d343e1f03f1b1ea995a68b9216..bbeba3f8ff6a8c91ae353326fc161c729aa7aa42 100644 (file)
@@ -26,8 +26,8 @@ $(eval $(call TestHostCommand,proper-umask, \
 ifndef IB
 $(eval $(call SetupHostCommand,gcc, \
        Please install the GNU C Compiler (gcc) 6 or later, \
-       $(CC) -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
-       gcc -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
+       $(CC) -dumpversion | grep -E '^([6-9]\.?|1[0-9]\.?)', \
+       gcc -dumpversion | grep -E '^([6-9]\.?|1[0-9]\.?)', \
        gcc --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-gcc, \
@@ -38,8 +38,8 @@ $(eval $(call TestHostCommand,working-gcc, \
 
 $(eval $(call SetupHostCommand,g++, \
        Please install the GNU C++ Compiler (g++) 6 or later, \
-       $(CXX) -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
-       g++ -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
+       $(CXX) -dumpversion | grep -E '^([6-9]\.?|1[0-9]\.?)', \
+       g++ -dumpversion | grep -E '^([6-9]\.?|1[0-9]\.?)', \
        g++ --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-g++, \