uhttpd: disable concurrent requests by default
authorJo-Philipp Wich <jo@mein.io>
Wed, 30 Jan 2019 09:12:00 +0000 (10:12 +0100)
committerJo-Philipp Wich <jo@mein.io>
Wed, 30 Jan 2019 09:12:00 +0000 (10:12 +0100)
In order to avoid straining CPU and memory resources on lower end devices,
avoid running multiple CGI requests in parallel.

Ref: https://forum.openwrt.org/t/high-load-fix-on-openwrt-luci/29006
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/network/services/uhttpd/Makefile
package/network/services/uhttpd/files/uhttpd.config

index da426d47002ea979674330555d8bbf2acc3b2743..29f1c89f127820dbf3efddee1b81927a88a42d02 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/uhttpd.git
index a3deb9cf04356fbd84396fb583b81158714db266..8b7d84c20662e94e244c5103744ec77a7691fe7c 100644 (file)
@@ -24,7 +24,7 @@ config uhttpd main
        # If this number is exceeded, further requests are
        # queued until the number of running requests drops
        # below the limit again.
-       option max_requests 3
+       option max_requests 1
 
        # Maximum number of concurrent connections.
        # If this number is exceeded, further TCP connection