kernel: bump 4.19 to 4.19.74
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 20 Sep 2019 13:11:19 +0000 (15:11 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 20 Sep 2019 13:51:49 +0000 (15:51 +0200)
Refreshed all patches.

Fixes:
- CVE-2019-15504

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm2708/patches-4.19/950-0129-gpiolib-Don-t-prevent-IRQ-usage-of-output-GPIOs.patch
target/linux/brcm2708/patches-4.19/950-0392-nvmem-add-type-attribute.patch
target/linux/brcm2708/patches-4.19/950-0802-regulator-gpio-Allow-nonexclusive-GPIO-access.patch
target/linux/brcm2708/patches-4.19/950-0803-gpio-Enable-nonexclusive-gpiods-from-DT-nodes.patch
target/linux/generic/hack-4.19/204-module_strip.patch
target/linux/generic/hack-4.19/661-use_fq_codel_by_default.patch
target/linux/generic/hack-4.19/662-remove_pfifo_fast.patch
target/linux/generic/pending-4.19/132-spi-spi-gpio-fix-crash-when-num-chipselects-is-0.patch

index 7f4ba25930a13a850ae988a84349d1b355f549b8..2cb4a4344a25cdff213c89207662bc1de60f0287 100644 (file)
@@ -8,11 +8,11 @@ endif
 
 LINUX_VERSION-4.9 = .193
 LINUX_VERSION-4.14 = .145
-LINUX_VERSION-4.19 = .73
+LINUX_VERSION-4.19 = .74
 
 LINUX_KERNEL_HASH-4.9.193 = 9be5081cc0fa6b720e6b3e5cb90296f3d857469bb3cda09ff93db00f9e16fd01
 LINUX_KERNEL_HASH-4.14.145 = eb05b5806713263a6d5bfa1e018ad07c3f4b3c6e71032306a94d7113ed594929
-LINUX_KERNEL_HASH-4.19.73 = 7db5e77ef2a2d8da4b128b7d47d7dd645ebcde2d19c1d191793e1eeefc275fab
+LINUX_KERNEL_HASH-4.19.74 = 495c2fead329c2c6b17950faa07ad7406e5aa93560e5e58de93a71197579ee82
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 9cb434693e0f4ade6769d3e83e93977e5efa50f7..d72064166d73a76edb997ab0787cc975b5925941 100644 (file)
@@ -26,7 +26,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  /* Device and char device-related information */
  static DEFINE_IDA(gpio_ida);
  static dev_t gpio_devt;
-@@ -2628,7 +2630,7 @@ int gpiod_direction_output(struct gpio_d
+@@ -2634,7 +2636,7 @@ int gpiod_direction_output(struct gpio_d
                value = !!value;
  
        /* GPIOs used for IRQs shall not be set as output */
@@ -35,7 +35,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
                gpiod_err(desc,
                          "%s: tried to set a GPIO tied to an IRQ as output\n",
                          __func__);
-@@ -3316,7 +3318,7 @@ int gpiochip_lock_as_irq(struct gpio_chi
+@@ -3322,7 +3324,7 @@ int gpiochip_lock_as_irq(struct gpio_chi
                }
        }
  
index 6065ad33f859eb2cc292a6154b0ffbac26428643..7e343f4dc7c1f3df2f67a507a93a99b524032c2c 100644 (file)
@@ -82,7 +82,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
  };
  
  static const struct attribute_group *nvmem_ro_root_dev_groups[] = {
-@@ -478,6 +498,7 @@ struct nvmem_device *nvmem_register(cons
+@@ -485,6 +505,7 @@ struct nvmem_device *nvmem_register(cons
        nvmem->dev.bus = &nvmem_bus_type;
        nvmem->dev.parent = config->dev;
        nvmem->priv = config->priv;
index c7d3c99613ffc3d74f4931d929fb0ad37f9c0138..4c258ad54ac38608b84f94037a8ce5fa3a9a0298 100644 (file)
@@ -41,7 +41,7 @@ Signed-off-by: Mark Brown <broonie@kernel.org>
 
 --- a/drivers/gpio/gpiolib.c
 +++ b/drivers/gpio/gpiolib.c
-@@ -3942,8 +3942,23 @@ struct gpio_desc *__must_check gpiod_get
+@@ -3948,8 +3948,23 @@ struct gpio_desc *__must_check gpiod_get
         * the device name as label
         */
        status = gpiod_request(desc, con_id ? con_id : devname);
index db58259ea11b8212beaaa58b007a5a017a96e3ed..4072f825b20fced5eef904625dcfc1c1e32e2ded 100644 (file)
@@ -23,7 +23,7 @@ Signed-off-by: Mark Brown <broonie@kernel.org>
 
 --- a/drivers/gpio/gpiolib.c
 +++ b/drivers/gpio/gpiolib.c
-@@ -4016,6 +4016,8 @@ struct gpio_desc *gpiod_get_from_of_node
+@@ -4022,6 +4022,8 @@ struct gpio_desc *gpiod_get_from_of_node
        transitory = flags & OF_GPIO_TRANSITORY;
  
        ret = gpiod_request(desc, label);
index 2524307f455451cc22d1405f95a6cbdf9ee37e09..b218e3b6a82493d370179e9af58b2d56b4f4727d 100644 (file)
@@ -114,7 +114,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  config MODULES_TREE_LOOKUP
 --- a/kernel/module.c
 +++ b/kernel/module.c
-@@ -3016,9 +3016,11 @@ static int setup_load_info(struct load_i
+@@ -3025,9 +3025,11 @@ static int setup_load_info(struct load_i
  
  static int check_modinfo(struct module *mod, struct load_info *info, int flags)
  {
@@ -127,7 +127,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (flags & MODULE_INIT_IGNORE_VERMAGIC)
                modmagic = NULL;
  
-@@ -3039,6 +3041,7 @@ static int check_modinfo(struct module *
+@@ -3048,6 +3050,7 @@ static int check_modinfo(struct module *
                                mod->name);
                add_taint_module(mod, TAINT_OOT_MODULE, LOCKDEP_STILL_OK);
        }
index 74adfa0c43f7c12f3a9bbab625b5f309cb4d43d2..fc0761c3c0ef3cbde87481001abc24db19066fe6 100644 (file)
@@ -83,7 +83,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  EXPORT_SYMBOL(default_qdisc_ops);
  
  /* Main transmission queue. */
-@@ -1004,7 +1004,7 @@ static void attach_one_default_qdisc(str
+@@ -1009,7 +1009,7 @@ static void attach_one_default_qdisc(str
                                     void *_unused)
  {
        struct Qdisc *qdisc;
index 0009940cd140c3097aab98fcab6bad86f9ae3555..d545cdf7ee378af8879c7462ed10e4828c725f8f 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/net/sched/sch_generic.c
 +++ b/net/sched/sch_generic.c
-@@ -595,207 +595,6 @@ struct Qdisc_ops noqueue_qdisc_ops __rea
+@@ -600,207 +600,6 @@ struct Qdisc_ops noqueue_qdisc_ops __rea
        .owner          =       THIS_MODULE,
  };
  
index 7c171745c23eb09e3790cdfb88c96c21bd61675b..ed94f937c94f0497af4d18473643b5c0cbcd0797 100644 (file)
@@ -43,11 +43,9 @@ Signed-off-by: Petr Štetiar <ynezz@true.cz>
  drivers/spi/spi-gpio.c | 10 ++++++----
  1 file changed, 6 insertions(+), 4 deletions(-)
 
-diff --git a/drivers/spi/spi-gpio.c b/drivers/spi/spi-gpio.c
-index 088772ebef9b..57d5b6dc0dd0 100644
 --- a/drivers/spi/spi-gpio.c
 +++ b/drivers/spi/spi-gpio.c
-@@ -242,10 +242,12 @@ static int spi_gpio_setup(struct spi_device *spi)
+@@ -242,10 +242,12 @@ static int spi_gpio_setup(struct spi_dev
         * The CS GPIOs have already been
         * initialized from the descriptor lookup.
         */