ath79: add support for the Belkin F9K1115 v2 (AC1750 DB Wi-Fi)
authorMartin Blumenstingl <martin.blumenstingl@googlemail.com>
Sat, 28 Nov 2020 11:08:42 +0000 (12:08 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 14 Dec 2020 15:59:49 +0000 (16:59 +0100)
This device has (almost?) identical hardware to the F9J1108 v2 but uses
a different firmware magic and model number.

Specifications:

SoC: QCA9558
CPU: 720 MHz
Flash: 16 MiB NOR
RAM: 128 MiB
WiFi 2.4 GHz: QCA9558-AT4A 3x3 MIMO 802.11b/g/n
WiFi 5 GHz: QCA9880-2R4E 3x3 MIMO 802.11a/n/ac
Ethernet: 4x LAN and 1x WAN (all 1Gbit/s ports)
USB: 1 x USB 2.0 (lower), 1 x USB 3.0 (upper)

MAC addresses based on OEM firmware:

Interface   Address   Location
---------   -------   --------
lan         *:5A      sometimes in 0x6
wan         *:5B      0x0
2.4Ghz      *:5A      0x1002
5Ghz        As per mini PCIe EEPROM

Flashing instructions:

The factory.bin can be flashed via the Belkin web UI or via the uboot
HTTP upgrade page (which is by default listening on 192.168.2.1). Once
the factory.bin has been written, sysupgrade.bin will work as usual.

Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
target/linux/ath79/dts/qca9558_belkin_f9k1115-v2.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/image/generic.mk

diff --git a/target/linux/ath79/dts/qca9558_belkin_f9k1115-v2.dts b/target/linux/ath79/dts/qca9558_belkin_f9k1115-v2.dts
new file mode 100644 (file)
index 0000000..aa5851c
--- /dev/null
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9558_belkin_f9x-v2.dtsi"
+
+/ {
+       model = "Belkin F9K1115 v2 (AC 1750 DB)";
+       compatible = "belkin,f9k1115-v2", "qca,qca9558";
+};
index 987b405431b66eb918bdfc542797b196757def83..905848a2badc4ab3803d9a4cea7a0a6ab6e069aa 100755 (executable)
@@ -101,6 +101,7 @@ ath79_setup_interfaces()
                        "0@eth0" "1:lan:1" "2:lan:4" "3:lan:3" "4:lan:2"
                ;;
        belkin,f9j1108-v2|\
+       belkin,f9k1115-v2|\
        tplink,archer-c5-v1|\
        tplink,archer-c7-v1|\
        tplink,archer-c7-v2|\
index 02fdf8ecad707030908f90d0d4f861428619d320..b3fca9eb8f7f98591c1a554fe27416662ff84e8c 100644 (file)
@@ -410,6 +410,14 @@ define Device/belkin_f9j1108-v2
 endef
 TARGET_DEVICES += belkin_f9j1108-v2
 
+define Device/belkin_f9k1115-v2
+  $(Device/belkin_f9x-v2)
+  DEVICE_MODEL := F9K1115 v2 (AC1750 DB Wi-Fi)
+  EDIMAX_HEADER_MAGIC := eDiMaX
+  EDIMAX_HEADER_MODEL := F9K1115V2
+endef
+TARGET_DEVICES += belkin_f9k1115-v2
+
 define Device/buffalo_bhr-4grv
   $(Device/buffalo_common)
   SOC := ar7242