sdk: keep the linux package in the same subdir as in the main build system
authorFelix Fietkau <nbd@nbd.name>
Mon, 19 Oct 2020 09:28:29 +0000 (11:28 +0200)
committerDavid Bauer <mail@david-bauer.net>
Mon, 26 Oct 2020 01:36:02 +0000 (02:36 +0100)
Fixes: 953435795d17 ("build: always build package/kernel/linux")
Signed-off-by: Felix Fietkau <nbd@nbd.name>
target/sdk/Makefile

index 022a791ebfee662a7ae4e966dd0abe64e80a75b7..4a9dc8be41b85c1e55f8f4e1cfc7e8fd68783fdd 100644 (file)
@@ -129,11 +129,14 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
                ./files/include/prepare.mk \
                ./files/README.SDK \
                $(SDK_BUILD_DIR)/
+       mkdir -p $(SDK_BUILD_DIR)/package/kernel
        $(CP) \
                $(TOPDIR)/package/Makefile \
                $(TOPDIR)/package/libs/toolchain \
-               $(TOPDIR)/package/kernel/linux \
                $(SDK_BUILD_DIR)/package/
+       $(CP) \
+               $(TOPDIR)/package/kernel/linux \
+               $(SDK_BUILD_DIR)/package/kernel/
 
        -rm -rf $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST)/.prereq-build