build: use config-1 instead of config@1 as default
authorRobert Marko <robert.marko@sartura.hr>
Thu, 4 Mar 2021 11:37:22 +0000 (12:37 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Fri, 5 Mar 2021 15:45:33 +0000 (15:45 +0000)
U-boot will reject all nodes with @ since commit:
https://gitlab.denx.de/u-boot/u-boot/-/commit/79af75f7776fc20b0d7eb6afe1e27c00fdb4b9b4

This will cause the OpenWrt images to fail booting,
to rectify use the config-1 as default.

Signed-off-by: Robert Marko <robert.marko@sartura.hr>
include/image-commands.mk
include/image.mk

index 10b23e027b1de8b123ee5a3683e9f2e524a2ad5e..daa01a3d099e2530bfcfa0e3faddef1456c03516 100644 (file)
@@ -214,7 +214,7 @@ define Build/fit
                                -i $(KERNEL_BUILD_DIR)/initrd.cpio$(strip $(call Build/initrd_compression)))) \
                -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
                $(if $(DEVICE_FDT_NUM),-n $(DEVICE_FDT_NUM)) \
-               -c $(if $(DEVICE_DTS_CONFIG),$(DEVICE_DTS_CONFIG),"config@1") \
+               -c $(if $(DEVICE_DTS_CONFIG),$(DEVICE_DTS_CONFIG),"config-1") \
                -A $(LINUX_KARCH) -v $(LINUX_VERSION)
        PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage $(if $(findstring external,$(word 3,$(1))),\
                -E -B 0x1000 $(if $(findstring static,$(word 3,$(1))),-p 0x1000)) -f $@.its $@.new
index 993de5ff53d70cd713bea4d37b3509036446cce7..cae3e734389c63d5036e61411b9809bba5461eee 100644 (file)
@@ -139,7 +139,7 @@ endef
 define Image/BuildKernel/MkFIT
        $(TOPDIR)/scripts/mkits.sh \
                -D $(1) -o $(KDIR)/fit-$(1).its -k $(2) $(if $(3),-d $(3)) -C $(4) -a $(5) -e $(6) \
-               -c $(if $(DEVICE_DTS_CONFIG),$(DEVICE_DTS_CONFIG),"config@1") \
+               -c $(if $(DEVICE_DTS_CONFIG),$(DEVICE_DTS_CONFIG),"config-1") \
                -A $(LINUX_KARCH) -v $(LINUX_VERSION)
        PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $(KDIR)/fit-$(1).its $(KDIR)/fit-$(1)$(7).itb
 endef