bpftools: fix libbpf pkgconfig file
authorTony Ambardar <itugrok@yahoo.com>
Mon, 1 Mar 2021 09:07:45 +0000 (01:07 -0800)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 7 Mar 2021 20:07:22 +0000 (20:07 +0000)
The pkgconfig file hardcodes a host library directory which cannot be
overridden by OpenWrt during builds. Use SED to fix this and potential
include directory problems, as is done with several other packages.

This fixes a strange issue intermittently seen building iproute2 on the
oxnas target:

iptables modules directory: /usr/lib/iptables
libc has setns: yes
SELinux support: no
libbpf support: no
libbpf version 0.3.0 is too low, please update it to at least 0.1.0
LIBBPF_FORCE=on set, but couldn't find a usable libbpf

Fixes: 2f0d672088c3 ("bpftools: add utility and library packages
supporting eBPF usage")
Reported-by: Russell Senior <russell@personaltelco.net>
Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
package/network/utils/bpftools/Makefile

index a466c82e9f1a68c10cf1190dbedebf60b8d7df1f..15bed2d89e5c26069e46052336abc9c9f4eda8b4 100644 (file)
@@ -145,6 +145,10 @@ define Build/InstallDev/libbpf
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib$(LIB_SUFFIX)/pkgconfig/libbpf.pc \
                $(1)/usr/lib/pkgconfig/
+       $(SED) 's,/usr/include,$$$${prefix}/include,g' \
+               $(1)/usr/lib/pkgconfig/libbpf.pc
+       $(SED) 's,/usr/lib,$$$${exec_prefix}/lib,g' \
+               $(1)/usr/lib/pkgconfig/libbpf.pc
 endef
 
 ifeq ($(BUILD_VARIANT),lib)