kernel: bump 4.19 to 4.19.77
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 7 Oct 2019 11:09:31 +0000 (13:09 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 8 Oct 2019 10:44:35 +0000 (12:44 +0200)
Refreshed all patches.

Remove upstreamed:
- 110-ARM-zynq-Use-memcpy_toio-instead-of-memcpy.patch

Compile-tested on: cns3xxx, imx6
Runtime-tested on: cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm2708/patches-4.19/950-0014-dmaengine-bcm2835-Load-driver-early-and-support-lega.patch
target/linux/brcm2708/patches-4.19/950-0531-pcie-brcmstb-Changes-for-BCM2711.patch
target/linux/brcm2708/patches-4.19/950-0534-mmc-sdhci-Mask-spurious-interrupts.patch
target/linux/brcm2708/patches-4.19/950-0643-bcm2835-dma-Add-proper-40-bit-DMA-support.patch
target/linux/generic/hack-4.19/550-loop-better-discard-for-block-devices.patch
target/linux/generic/hack-4.19/661-use_fq_codel_by_default.patch
target/linux/zynq/patches-4.19/110-ARM-zynq-Use-memcpy_toio-instead-of-memcpy.patch [deleted file]

index 0208feed8c97d08991378a5f1b8003bbdf309b50..c310ea4f34278af069b6105569b55b014ba1bb73 100644 (file)
@@ -8,11 +8,11 @@ endif
 
 LINUX_VERSION-4.9 = .195
 LINUX_VERSION-4.14 = .147
-LINUX_VERSION-4.19 = .76
+LINUX_VERSION-4.19 = .77
 
 LINUX_KERNEL_HASH-4.9.195 = 54be562a2da16eecd612f641146dc099c1aa05c0fc559c971bdfde161c929d68
 LINUX_KERNEL_HASH-4.14.147 = 8fd793688c9d9d4e26fdc175be92b6e638b6a86f4150dd66edecebab0bb85b12
-LINUX_KERNEL_HASH-4.19.76 = ba4dd29902734b263a5197410363b17f30dc60bc999bd6ce90b6f5910b971e66
+LINUX_KERNEL_HASH-4.19.77 = 612b69cc494f2da1530bacac17291339e272cde7f2a7669e615f565506d5f3a9
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 03c4a0a6c779b2d852eea16020ede1c3a595626a..b43e7a04513fcb85dc4a20b0b86b693b81cda395 100644 (file)
@@ -47,7 +47,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
  
  struct bcm2835_dmadev {
        struct dma_device ddev;
-@@ -912,6 +914,9 @@ static int bcm2835_dma_probe(struct plat
+@@ -914,6 +916,9 @@ static int bcm2835_dma_probe(struct plat
        base = devm_ioremap_resource(&pdev->dev, res);
        if (IS_ERR(base))
                return PTR_ERR(base);
@@ -57,7 +57,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
  
        od->base = base;
  
-@@ -950,6 +955,9 @@ static int bcm2835_dma_probe(struct plat
+@@ -952,6 +957,9 @@ static int bcm2835_dma_probe(struct plat
                goto err_no_dma;
        }
  
@@ -67,7 +67,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
        /* get irqs for each channel that we support */
        for (i = 0; i <= BCM2835_DMA_MAX_DMA_CHAN_SUPPORTED; i++) {
                /* skip masked out channels */
-@@ -1024,6 +1032,7 @@ static int bcm2835_dma_remove(struct pla
+@@ -1026,6 +1034,7 @@ static int bcm2835_dma_remove(struct pla
  {
        struct bcm2835_dmadev *od = platform_get_drvdata(pdev);
  
@@ -75,7 +75,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
        dma_async_device_unregister(&od->ddev);
        bcm2835_dma_free(od);
  
-@@ -1039,7 +1048,22 @@ static struct platform_driver bcm2835_dm
+@@ -1041,7 +1050,22 @@ static struct platform_driver bcm2835_dm
        },
  };
  
index 86f638e73607b2140d6cc8c07f53fca1ce6428ea..58803a8bdd982fc3f8eac2b4bef23b6e8a88c378 100644 (file)
@@ -143,7 +143,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  static const struct of_device_id bcm2835_dma_of_match[] = {
        { .compatible = "brcm,bcm2835-dma", },
        {},
-@@ -964,6 +1064,13 @@ static int bcm2835_dma_probe(struct plat
+@@ -966,6 +1066,13 @@ static int bcm2835_dma_probe(struct plat
        /* Channel 0 is used by the legacy API */
        chans_available &= ~BCM2835_DMA_BULK_MASK;
  
index 280c032c16eaece08037bb00464e298251ea7a50..e28fee443fb8bb8c56472c3dc52fa87665f67a4c 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/drivers/mmc/host/sdhci.c
 +++ b/drivers/mmc/host/sdhci.c
-@@ -2930,6 +2930,10 @@ static irqreturn_t sdhci_irq(int irq, vo
+@@ -2932,6 +2932,10 @@ static irqreturn_t sdhci_irq(int irq, vo
                        result = IRQ_WAKE_THREAD;
                }
  
index c43939ec6d81c34faf4243978bfa9864483f2ec0..94d2c9a9b29224d2898e79b9631e562bf636ccd4 100644 (file)
@@ -713,7 +713,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  
        if (!pdev->dev.dma_mask)
                pdev->dev.dma_mask = &pdev->dev.coherent_dma_mask;
-@@ -1020,9 +1206,13 @@ static int bcm2835_dma_probe(struct plat
+@@ -1022,9 +1208,13 @@ static int bcm2835_dma_probe(struct plat
        base = devm_ioremap_resource(&pdev->dev, res);
        if (IS_ERR(base))
                return PTR_ERR(base);
@@ -730,7 +730,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  
        od->base = base;
  
-@@ -1052,6 +1242,14 @@ static int bcm2835_dma_probe(struct plat
+@@ -1054,6 +1244,14 @@ static int bcm2835_dma_probe(struct plat
  
        platform_set_drvdata(pdev, od);
  
@@ -745,7 +745,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        /* Request DMA channel mask from device tree */
        if (of_property_read_u32(pdev->dev.of_node,
                        "brcm,dma-channel-mask",
-@@ -1061,18 +1259,34 @@ static int bcm2835_dma_probe(struct plat
+@@ -1063,18 +1261,34 @@ static int bcm2835_dma_probe(struct plat
                goto err_no_dma;
        }
  
@@ -788,7 +788,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
                /* skip masked out channels */
                if (!(chans_available & (1 << i))) {
                        irq[i] = -1;
-@@ -1095,13 +1309,17 @@ static int bcm2835_dma_probe(struct plat
+@@ -1097,13 +1311,17 @@ static int bcm2835_dma_probe(struct plat
                irq[i] = platform_get_irq(pdev, i < 11 ? i : 11);
        }
  
@@ -807,7 +807,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
                irq_flags = 0;
                for (j = 0; j <= BCM2835_DMA_MAX_DMA_CHAN_SUPPORTED; j++)
                        if ((i != j) && (irq[j] == irq[i])) {
-@@ -1113,9 +1331,10 @@ static int bcm2835_dma_probe(struct plat
+@@ -1115,9 +1333,10 @@ static int bcm2835_dma_probe(struct plat
                rc = bcm2835_dma_chan_init(od, i, irq[i], irq_flags);
                if (rc)
                        goto err_no_dma;
@@ -819,7 +819,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  
        /* Device-tree DMA controller registration */
        rc = of_dma_controller_register(pdev->dev.of_node,
-@@ -1147,6 +1366,13 @@ static int bcm2835_dma_remove(struct pla
+@@ -1149,6 +1368,13 @@ static int bcm2835_dma_remove(struct pla
  
        bcm_dmaman_remove(pdev);
        dma_async_device_unregister(&od->ddev);
index d6f0f3df0a7af0675aad3a5d25d2e06b6e1102cf..9701d945e63034d11a2a989ece0489f7a5633ca7 100644 (file)
@@ -150,7 +150,7 @@ Reviewed-by: Chaitanya Kulkarni <chaitanya.kulkarni@wdc.com>
  }
  
  static void loop_unprepare_queue(struct loop_device *lo)
-@@ -1893,7 +1912,10 @@ static void loop_handle_cmd(struct loop_
+@@ -1894,7 +1913,10 @@ static void loop_handle_cmd(struct loop_
   failed:
        /* complete non-aio request */
        if (!cmd->use_aio || ret) {
index d86138a1323e27b11caa91b04ab051a10c853154..16d8f5d67c9b32f9d0fc141d5c36b568ea56338c 100644 (file)
@@ -44,7 +44,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
          device, it has to decide which ones to send first, which ones to
 --- a/net/sched/sch_api.c
 +++ b/net/sched/sch_api.c
-@@ -2159,7 +2159,7 @@ static int __init pktsched_init(void)
+@@ -2160,7 +2160,7 @@ static int __init pktsched_init(void)
                return err;
        }
  
diff --git a/target/linux/zynq/patches-4.19/110-ARM-zynq-Use-memcpy_toio-instead-of-memcpy.patch b/target/linux/zynq/patches-4.19/110-ARM-zynq-Use-memcpy_toio-instead-of-memcpy.patch
deleted file mode 100644 (file)
index 03027b2..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-From a801d4aa6000f7ba0ffc5ba9d841af62ec7e0bb1 Mon Sep 17 00:00:00 2001
-From: Luis Araneda <luaraneda@gmail.com>
-Date: Tue, 30 Jul 2019 00:29:03 -0400
-Subject: [RFC PATCH] ARM: zynq: Use memcpy_toio instead of memcpy on smp bring-up
-
-This fixes a kernel panic (read overflow) on memcpy when
-FORTIFY_SOURCE is enabled.
-
-The computed size of memcpy args are:
-- p_size (dst): 4294967295 = (size_t) -1
-- q_size (src): 1
-- size (len): 8
-
-Additionally, the memory is marked as __iomem, so one of
-the memcpy_* functions should be used for read/write
-
-Signed-off-by: Luis Araneda <luaraneda@gmail.com>
----
-As of 2019-08-03, this patch is under review and waiting
-comments from the maintainer / author
---
- arch/arm/mach-zynq/platsmp.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/arch/arm/mach-zynq/platsmp.c
-+++ b/arch/arm/mach-zynq/platsmp.c
-@@ -65,7 +65,7 @@ int zynq_cpun_start(u32 address, int cpu
-                       * 0x4: Jump by mov instruction
-                       * 0x8: Jumping address
-                       */
--                      memcpy((__force void *)zero, &zynq_secondary_trampoline,
-+                      memcpy_toio(zero, &zynq_secondary_trampoline,
-                                                       trampoline_size);
-                       writel(address, zero + trampoline_size);