build: fix getting ABI version for binary packages from the same source package
authorFelix Fietkau <nbd@nbd.name>
Mon, 15 Feb 2021 22:09:53 +0000 (23:09 +0100)
committerFelix Fietkau <nbd@nbd.name>
Mon, 15 Feb 2021 22:11:44 +0000 (23:11 +0100)
We can't rely on the .version file being created yet, so use package variables
to get it

Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/feeds.mk

index 5676cc4a8f6b3f43d054f5e3d9aa06f036c645ed..98e315bceb5eab214638acdfeca3a309c0a295bb 100644 (file)
@@ -43,5 +43,5 @@ endef
 
 # 1: package name
 define GetABISuffix
-$(if $(filter-out kmod-%,$(1)),$(foreach v,$(wildcard $(STAGING_DIR)/pkginfo/$(1).version),$(shell cat $(v))))
+$(if $(filter-out kmod-%,$(1)),$(if $(ABIV_$(1)),$(ABIV_$(1)),$(foreach v,$(wildcard $(STAGING_DIR)/pkginfo/$(1).version),$(shell cat $(v)))))
 endef