kernel: bump 4.19 to 4.19.76
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 4 Oct 2019 10:20:58 +0000 (12:20 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 4 Oct 2019 13:48:28 +0000 (15:48 +0200)
Refreshed all patches.

Altered patches:
- 403-mtd_fix_cfi_cmdset_0002_status_check.patch

Compile-tested on: ath79, cns3xxx, imx6
Runtime-tested on: cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/ath79/patches-4.19/403-mtd_fix_cfi_cmdset_0002_status_check.patch
target/linux/brcm2708/patches-4.19/950-0730-hid-usb-Add-device-quirks-for-Freeway-Airmouse-T3-an.patch
target/linux/generic/hack-4.19/661-use_fq_codel_by_default.patch
target/linux/generic/pending-4.19/461-mtd-cfi_cmdset_0002-add-buffer-write-cmd-timeout.patch

index 5848590e8295b68d60f647a6f487ceb6b945c774..01e90b3ce4f6db88b13586844852ba17bed6a38a 100644 (file)
@@ -8,11 +8,11 @@ endif
 
 LINUX_VERSION-4.9 = .194
 LINUX_VERSION-4.14 = .146
-LINUX_VERSION-4.19 = .75
+LINUX_VERSION-4.19 = .76
 
 LINUX_KERNEL_HASH-4.9.194 = d5f4bb7584e461f1faa9a3f94c2ad292246fe692b0e992e072dac255f806c2e3
 LINUX_KERNEL_HASH-4.14.146 = a3c54b887ea3e679382bd4c0536e6a281b071dab2258bd3ee8af75baef2023f5
-LINUX_KERNEL_HASH-4.19.75 = dd5e7147e1e4501560fba5beb86dae6bf6ba843518ab3d4cad283de77b651b78
+LINUX_KERNEL_HASH-4.19.76 = ba4dd29902734b263a5197410363b17f30dc60bc999bd6ce90b6f5910b971e66
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index eeda6209573a749406dd66cb594b45e32a61869c..702e2a5b091829ca9b110428f43092fc58c6dd4d 100644 (file)
@@ -1,26 +1,24 @@
 --- a/drivers/mtd/chips/cfi_cmdset_0002.c
 +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -1634,8 +1634,8 @@ static int __xipram do_write_oneword(str
-                       break;
+@@ -1640,7 +1640,7 @@ static int __xipram do_write_oneword(str
                }
  
--              if (chip_ready(map, adr))
+               if (chip_good(map, adr, datum))
 -                      break;
-+              if (chip_good(map, adr, datum))
 +                      goto enable_xip;
  
                /* Latency issues. Drop the lock, wait a while and retry */
                UDELAY(map, chip, adr, 1);
-@@ -1651,6 +1651,8 @@ static int __xipram do_write_oneword(str
-               ret = -EIO;
+@@ -1657,6 +1657,8 @@ static int __xipram do_write_oneword(str
+                       goto retry;
+               }
        }
 +
 + enable_xip:
        xip_enable(map, chip, adr);
   op_done:
        if (mode == FL_OTP_WRITE)
-@@ -2229,7 +2231,6 @@ static int cfi_amdstd_panic_write(struct
+@@ -2235,7 +2237,6 @@ static int cfi_amdstd_panic_write(struct
        return 0;
  }
  
@@ -28,7 +26,7 @@
  /*
   * Handle devices with one erase region, that only implement
   * the chip erase command.
-@@ -2297,7 +2298,7 @@ static int __xipram do_erase_chip(struct
+@@ -2303,7 +2304,7 @@ static int __xipram do_erase_chip(struct
                }
  
                if (chip_good(map, adr, map_word_ff(map)))
@@ -37,7 +35,7 @@
  
                if (time_after(jiffies, timeo)) {
                        printk(KERN_WARNING "MTD %s(): software timeout\n",
-@@ -2321,6 +2322,7 @@ static int __xipram do_erase_chip(struct
+@@ -2327,6 +2328,7 @@ static int __xipram do_erase_chip(struct
                }
        }
  
@@ -45,7 +43,7 @@
        chip->state = FL_READY;
        xip_enable(map, chip, adr);
        DISABLE_VPP(map);
-@@ -2393,7 +2395,7 @@ static int __xipram do_erase_oneblock(st
+@@ -2399,7 +2401,7 @@ static int __xipram do_erase_oneblock(st
                }
  
                if (chip_good(map, adr, map_word_ff(map)))
@@ -54,7 +52,7 @@
  
                if (time_after(jiffies, timeo)) {
                        printk(KERN_WARNING "MTD %s(): software timeout\n",
-@@ -2417,6 +2419,7 @@ static int __xipram do_erase_oneblock(st
+@@ -2423,6 +2425,7 @@ static int __xipram do_erase_oneblock(st
                }
        }
  
index 8a2642151180262063472d01711da4a4ff3344c0..9e9c79280d0acaee14b432a60d608021b4a2b107 100644 (file)
@@ -33,7 +33,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
  #define USB_VENDOR_ID_BELKIN          0x050d
  #define USB_DEVICE_ID_FLIP_KVM                0x3201
  
-@@ -1188,6 +1191,9 @@
+@@ -1189,6 +1192,9 @@
  #define USB_VENDOR_ID_XAT     0x2505
  #define USB_DEVICE_ID_XAT_CSR 0x0220
  
@@ -53,7 +53,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
        { HID_USB_DEVICE(USB_VENDOR_ID_CHICONY, USB_DEVICE_ID_CHICONY_MULTI_TOUCH), HID_QUIRK_MULTI_INPUT },
        { HID_USB_DEVICE(USB_VENDOR_ID_CHICONY, USB_DEVICE_ID_CHICONY_PIXART_USB_OPTICAL_MOUSE), HID_QUIRK_ALWAYS_POLL },
        { HID_USB_DEVICE(USB_VENDOR_ID_CHICONY, USB_DEVICE_ID_CHICONY_PIXART_USB_OPTICAL_MOUSE2), HID_QUIRK_ALWAYS_POLL },
-@@ -173,6 +174,7 @@ static const struct hid_device_id hid_qu
+@@ -174,6 +175,7 @@ static const struct hid_device_id hid_qu
        { HID_USB_DEVICE(USB_VENDOR_ID_WALTOP, USB_DEVICE_ID_WALTOP_SIRIUS_BATTERY_FREE_TABLET), HID_QUIRK_MULTI_INPUT },
        { HID_USB_DEVICE(USB_VENDOR_ID_WISEGROUP_LTD2, USB_DEVICE_ID_SMARTJOY_DUAL_PLUS), HID_QUIRK_NOGET | HID_QUIRK_MULTI_INPUT },
        { HID_USB_DEVICE(USB_VENDOR_ID_WISEGROUP, USB_DEVICE_ID_QUAD_USB_JOYPAD), HID_QUIRK_NOGET | HID_QUIRK_MULTI_INPUT },
index d147c0d74307cc41ffd4d724a3d3bbc7e190c1be..d86138a1323e27b11caa91b04ab051a10c853154 100644 (file)
@@ -44,7 +44,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
          device, it has to decide which ones to send first, which ones to
 --- a/net/sched/sch_api.c
 +++ b/net/sched/sch_api.c
-@@ -2157,7 +2157,7 @@ static int __init pktsched_init(void)
+@@ -2159,7 +2159,7 @@ static int __init pktsched_init(void)
                return err;
        }
  
index f4ba5b72f7a9aba9c21803d706ddb116c82158cf..1b07791ecafd8adb9dee035aef68307152103f4d 100644 (file)
@@ -7,7 +7,7 @@ Signed-off-by: George Kashperko <george@znau.edu.ua>
  1 file changed, 1 insertion(+)
 --- a/drivers/mtd/chips/cfi_cmdset_0002.c
 +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -1832,6 +1832,7 @@ static int __xipram do_write_buffer(stru
+@@ -1838,6 +1838,7 @@ static int __xipram do_write_buffer(stru
  
        /* Write Buffer Load */
        map_write(map, CMD(0x25), cmd_adr);