ath79: rename glinet x750
authorMathias Kresin <dev@kresin.me>
Mon, 26 Nov 2018 14:39:25 +0000 (15:39 +0100)
committerMathias Kresin <dev@kresin.me>
Tue, 27 Nov 2018 20:11:54 +0000 (21:11 +0100)
The boardname is gl-x750 and is already used for the led names.

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/dts/qca9533_glinet_gl-x750.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9533_glinet_x750.dts [deleted file]
target/linux/ath79/dts/qca9533_glinet_x750.dtsi
target/linux/ath79/image/generic.mk

index 7945ecba1f080718e2be318e53d9c98212b63bd3..06fb8f4791c61492e1388a7adb6a6950400e0593 100755 (executable)
@@ -33,8 +33,8 @@ etactica,eg200)
        ucidef_set_led_oneshot "modbus" "Modbus" "$boardname:red:modbus" "100" "33"
        ucidef_set_led_default "etactica" "etactica" "$boardname:red:etactica" "ignore"
        ;;
-glinet,x750)
-       ucidef_set_led_netdev "wan" "WAN" "gl-x750:green:wan" "eth0"
+glinet,gl-x750)
+       ucidef_set_led_netdev "wan" "WAN" "$boardname:green:wan" "eth0"
        ;;
 netgear,wnr612-v2|\
 on,n150r)
index 202820d50bea051203050ea76d755e0d75bf27ee..f4718822134e95acb5db04861236272cebc8b163 100755 (executable)
@@ -75,7 +75,7 @@ ath79_setup_interfaces()
                ;;
        glinet,ar150|\
        glinet,ar300m|\
-       glinet,x750)
+       glinet,gl-x750)
                ucidef_set_interfaces_lan_wan "eth1" "eth0"
                ;;
        iodata,etg3-r|\
index cbc5c961707a7dde459c1841236976c8a001d060..82c23e30794c40277d3743488dc764041af5c02f 100644 (file)
@@ -87,7 +87,7 @@ board=$(board_name)
 case "$FIRMWARE" in
 "ath10k/cal-pci-0000:00:00.0.bin")
        case $board in
-       glinet,x750)
+       glinet,gl-x750)
                ath10kcal_extract "art" 20480 2116
                ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +1)
                ;;
diff --git a/target/linux/ath79/dts/qca9533_glinet_gl-x750.dts b/target/linux/ath79/dts/qca9533_glinet_gl-x750.dts
new file mode 100644 (file)
index 0000000..7313f96
--- /dev/null
@@ -0,0 +1,46 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9533_glinet_x750.dtsi"
+
+&spi {
+       status = "okay";
+       num-cs = <0>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x040000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "u-boot-env";
+                               reg = <0x040000 0x010000>;
+                       };
+
+                        art: partition@50000 {
+                                label = "art";
+                                reg = <0x050000 0x010000>;
+                        };
+
+                       partition@60000 {
+                               label = "firmware";
+                               reg = <0x060000 0xfa0000>;
+                       };
+
+               };
+       };
+};
diff --git a/target/linux/ath79/dts/qca9533_glinet_x750.dts b/target/linux/ath79/dts/qca9533_glinet_x750.dts
deleted file mode 100644 (file)
index 7313f96..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-/dts-v1/;
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-#include "qca9533_glinet_x750.dtsi"
-
-&spi {
-       status = "okay";
-       num-cs = <0>;
-
-       flash@0 {
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <25000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "u-boot";
-                               reg = <0x000000 0x040000>;
-                               read-only;
-                       };
-
-                       partition@40000 {
-                               label = "u-boot-env";
-                               reg = <0x040000 0x010000>;
-                       };
-
-                        art: partition@50000 {
-                                label = "art";
-                                reg = <0x050000 0x010000>;
-                        };
-
-                       partition@60000 {
-                               label = "firmware";
-                               reg = <0x060000 0xfa0000>;
-                       };
-
-               };
-       };
-};
index b84c332137f9ca16cefc69ccf72a67cbd3535cda..e1f95d5f04dfdec584b7c5f4fa2e28092a0aa4d0 100644 (file)
@@ -4,7 +4,7 @@
 #include "qca9533.dtsi"
 
 / {
-       compatible = "glinet,x750", "qca,qca9533";
+       compatible = "glinet,gl-x750", "qca,qca9533";
        model = "GL.iNet GL-X750";
 
        keys {
index 9bdd8f6e350e70c41d2ad2ed95369dbb50e83419..48d477dd9e252a202c3c3b3084023f4bda5bce69 100644 (file)
@@ -183,13 +183,13 @@ define Device/glinet_ar300m_nor
 endef
 TARGET_DEVICES += glinet_ar300m_nor
 
-define Device/glinet_x750
+define Device/glinet_gl-x750
   ATH_SOC := qca9533
-  DEVICE_TITLE := GL.iNet GL-ARX750
+  DEVICE_TITLE := GL.iNet GL-X750
   DEVICE_PACKAGES := kmod-usb-core kmod-usb2  kmod-ath10k ath10k-firmware-qca9887
   IMAGE_SIZE := 16000k
 endef
-TARGET_DEVICES += glinet_x750
+TARGET_DEVICES += glinet_gl-x750
 
 define Device/iodata_etg3-r
   ATH_SOC := ar9342