build: build kernel image before building modules/packages
authorFelix Fietkau <nbd@nbd.name>
Thu, 22 Oct 2020 08:29:34 +0000 (10:29 +0200)
committerFelix Fietkau <nbd@nbd.name>
Tue, 16 Feb 2021 19:00:41 +0000 (20:00 +0100)
This is needed for linux 5.10, where modules.builtin is generated from
vmlinux.o

Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/kernel-defaults.mk

index e5a0ba367bffd5a09556a039d6c81940bed9dcd8..b069c1e67119323e176fde58fbbf99e275af2d70 100644 (file)
@@ -113,7 +113,7 @@ endef
 
 define Kernel/CompileModules/Default
        rm -f $(LINUX_DIR)/vmlinux $(LINUX_DIR)/System.map
-       +$(KERNEL_MAKE) modules
+       +$(KERNEL_MAKE) $(if $(KERNELNAME),$(KERNELNAME),all) modules
 endef
 
 OBJCOPY_STRIP = -R .reginfo -R .notes -R .note -R .comment -R .mdebug -R .note.gnu.build-id
@@ -137,7 +137,7 @@ endef
 
 define Kernel/CompileImage/Default
        rm -f $(TARGET_DIR)/init
-       +$(KERNEL_MAKE) $(if $(KERNELNAME),$(KERNELNAME),all) modules
+       +$(KERNEL_MAKE) $(if $(KERNELNAME),$(KERNELNAME),all)
        $(call Kernel/CopyImage)
 endef
 
@@ -147,7 +147,7 @@ define Kernel/CompileImage/Initramfs
        $(CP) $(GENERIC_PLATFORM_DIR)/other-files/init $(TARGET_DIR)/init
        $(if $(SOURCE_DATE_EPOCH),touch -hcd "@$(SOURCE_DATE_EPOCH)" $(TARGET_DIR)/init)
        rm -rf $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)/usr/initramfs_data.cpio*
-       +$(KERNEL_MAKE) $(if $(KERNELNAME),$(KERNELNAME),all) modules
+       +$(KERNEL_MAKE) $(if $(KERNELNAME),$(KERNELNAME),all)
        $(call Kernel/CopyImage,-initramfs)
 endef
 else