bcm63xx: disable all devices with <= 4MiB flash and <= 32 MiB RAM
authorJonas Gorski <jonas.gorski@gmail.com>
Fri, 28 Feb 2020 11:00:29 +0000 (12:00 +0100)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Sun, 12 Apr 2020 18:45:21 +0000 (20:45 +0200)
Device with 4 MiB flash and 32 MiB RAM won't be able to run OpenWrt in
a sufficient manner without tweaks, so don't build images for them by
default.

This includes all BCM6338, BCM6345 and BCM6348 "generic" devices,
as there are no supported devices of these with more than that.

Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
target/linux/bcm63xx/image/bcm63xx.mk

index ccbc7f1325364e1bd9895600df06324c1b7ba0ef..64ddb6374d397aedbf393fd06e3b1756b7e4c3f2 100644 (file)
@@ -91,6 +91,7 @@ define Device/brcm_bcm96338w
   DEVICE_MODEL := 96338W
   CFE_BOARD_ID := 6338W
   CFE_CHIP_ID := 6338
+  DEFAULT := n
 endef
 TARGET_DEVICES += brcm_bcm96338w
 
@@ -112,6 +113,7 @@ define Device/brcm_bcm96348gw
   IMAGES += cfe-bc221.bin
   CFE_BOARD_ID := 96348GW
   CFE_CHIP_ID := 6348
+  DEFAULT := n
 endef
 TARGET_DEVICES += brcm_bcm96348gw
 
@@ -121,6 +123,7 @@ define Device/brcm_bcm96348gw-10
   DEVICE_MODEL := 96348GW-10
   CFE_BOARD_ID := 96348GW-10
   CFE_CHIP_ID := 6348
+  DEFAULT := n
 endef
 TARGET_DEVICES += brcm_bcm96348gw-10
 
@@ -130,6 +133,7 @@ define Device/brcm_bcm96348gw-11
   DEVICE_MODEL := 96348GW-11
   CFE_BOARD_ID := 96348GW-11
   CFE_CHIP_ID := 6348
+  DEFAULT := n
 endef
 TARGET_DEVICES += brcm_bcm96348gw-11
 
@@ -139,6 +143,7 @@ define Device/brcm_bcm96348r
   DEVICE_MODEL := 96348R
   CFE_BOARD_ID := 96348R
   CFE_CHIP_ID := 6348
+  DEFAULT := n
 endef
 TARGET_DEVICES += brcm_bcm96348r
 
@@ -513,6 +518,7 @@ define Device/d-link_dsl-274xb-c2
   CFE_BOARD_ID := 96358GW
   CFE_CHIP_ID := 6358
   DEVICE_PACKAGES := $(B43_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += d-link_dsl-274xb-c2
 
@@ -528,6 +534,7 @@ define Device/d-link_dsl-274xb-c3
   CFE_BOARD_ID := AW4139
   CFE_CHIP_ID := 6358
   DEVICE_PACKAGES := $(B43_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += d-link_dsl-274xb-c3
 
@@ -648,6 +655,7 @@ define Device/huawei_echolife-hg520v
   CFE_EXTRAS += --rsa-signature "EchoLife_HG520v"
   SOC := bcm6359
   DEVICE_PACKAGES := $(B43_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += huawei_echolife-hg520v
 
@@ -1057,6 +1065,7 @@ define Device/tecom_gw6000
   CFE_BOARD_ID := 96348GW
   CFE_CHIP_ID := 6348
   DEVICE_PACKAGES := $(BRCMWL_PACKAGES) $(USB1_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += tecom_gw6000
 
@@ -1068,6 +1077,7 @@ define Device/tecom_gw6200
   CFE_CHIP_ID := 6348
   CFE_EXTRAS += --rsa-signature "$(shell printf '\x99')"
   DEVICE_PACKAGES := $(BRCMWL_PACKAGES) $(USB1_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += tecom_gw6200
 
@@ -1148,5 +1158,6 @@ define Device/zyxel_p870hw-51a-v2
   CFE_CHIP_ID := 6368
   CFE_EXTRAS += --rsa-signature "ZyXEL" --signature "ZyXEL_0001"
   DEVICE_PACKAGES := $(B43_PACKAGES)
+  DEFAULT := n
 endef
 TARGET_DEVICES += zyxel_p870hw-51a-v2