kernel: bump 4.14 to 4.14.148
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 8 Oct 2019 13:02:52 +0000 (15:02 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 8 Oct 2019 13:51:06 +0000 (15:51 +0200)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.14/025-tcp-allow-drivers-to-tweak-TSQ-logic.patch
target/linux/generic/hack-4.14/901-debloat_sock_diag.patch
target/linux/generic/hack-4.14/902-debloat_proc.patch
target/linux/generic/pending-4.14/240-remove-unsane-filenames-from-deps_initramfs-list.patch

index efe8940988e1f111f0a6fed7b166d460029b870f..5e3df8e4244e073b9972c3ea060dd393f1c399d3 100644 (file)
@@ -7,11 +7,11 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-4.9 = .196
-LINUX_VERSION-4.14 = .147
+LINUX_VERSION-4.14 = .148
 LINUX_VERSION-4.19 = .77
 
 LINUX_KERNEL_HASH-4.9.196 = e0ab12b04a975630ece2142a1ac15cfe45140b8c3359226b035c15ca7c92c6ef
-LINUX_KERNEL_HASH-4.14.147 = 8fd793688c9d9d4e26fdc175be92b6e638b6a86f4150dd66edecebab0bb85b12
+LINUX_KERNEL_HASH-4.14.148 = 12d2b74003e13a6c1956064754255249fbe5c7af6cbdfb2ddeba45b5ed7c0fad
 LINUX_KERNEL_HASH-4.19.77 = 612b69cc494f2da1530bacac17291339e272cde7f2a7669e615f565506d5f3a9
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index fc644cec589f7b4b213305eb228c76fae456934d..484093d55acbd03d6f7e1c4c38b19d5a93f22ba4 100644 (file)
@@ -55,7 +55,7 @@ Cc: Kir Kolyshkin <kir@openvz.org>
        rwlock_t                sk_callback_lock;
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -2740,6 +2740,7 @@ void sock_init_data(struct socket *sock,
+@@ -2745,6 +2745,7 @@ void sock_init_data(struct socket *sock,
  
        sk->sk_max_pacing_rate = ~0U;
        sk->sk_pacing_rate = ~0U;
index 118b1a79c693d403971ff3f5c759151415a0a545..5945aee55669504d32aa6d99c73cbb4142236d50 100644 (file)
@@ -61,7 +61,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  struct dst_entry *__sk_dst_check(struct sock *sk, u32 cookie)
  {
        struct dst_entry *dst = __sk_dst_get(sk);
-@@ -1593,9 +1605,11 @@ void sk_destruct(struct sock *sk)
+@@ -1598,9 +1610,11 @@ void sk_destruct(struct sock *sk)
  
  static void __sk_free(struct sock *sk)
  {
index aedefb32b4f2cf1ed6dbef82eaf9c6c4fd6ca7b0..6a2e6175a74feecca8f376bdcec47ae17edf3ac2 100644 (file)
@@ -327,7 +327,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -3379,6 +3379,8 @@ static __net_initdata struct pernet_oper
+@@ -3384,6 +3384,8 @@ static __net_initdata struct pernet_oper
  
  static int __init proto_init(void)
  {
index f440305c9bfdcbd5efef05ea91514b5dfd0b6cf9..c0dfe49c9bfe03080e00de696b6843684746a9bd 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
 
 --- a/usr/Makefile
 +++ b/usr/Makefile
-@@ -39,20 +39,22 @@ ifneq ($(wildcard $(obj)/$(datafile_d_y)
+@@ -42,20 +42,22 @@ ifneq ($(wildcard $(obj)/$(datafile_d_y)
        include $(obj)/$(datafile_d_y)
  endif