kernel: other.mk: add pps-gpio support
authorLuka Perkov <luka@openwrt.org>
Fri, 23 May 2014 09:35:27 +0000 (09:35 +0000)
committerLuka Perkov <luka@openwrt.org>
Fri, 23 May 2014 09:35:27 +0000 (09:35 +0000)
The pps-gpio kernel module supports Pulse-Per-Second provided by a GPIO.

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
SVN-Revision: 40831

package/kernel/linux/modules/other.mk

index 00c73fc92010c10cae1ad690f12bfb3c735ca88b..8f68bd8251c8079b25cdca19b536f5dc563100fc 100644 (file)
@@ -775,6 +775,24 @@ endef
 $(eval $(call KernelPackage,pps))
 
 
+define KernelPackage/pps-gpio
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=PPS client using GPIO
+  DEPENDS:=+kmod-pps
+  KCONFIG:=CONFIG_PPS_CLIENT_GPIO
+  FILES:=$(LINUX_DIR)/drivers/pps/clients/pps-gpio.ko
+  AUTOLOAD:=$(call AutoLoad,18,pps-gpio,1)
+endef
+
+define KernelPacakge/pps-gpio/description
+ Support for a PPS source using GPIO. To be useful you must
+ also register a platform device specifying the GPIO pin and
+ other options, usually in your board setup.
+endef
+
+$(eval $(call KernelPackage,pps-gpio))
+
+
 define KernelPackage/ptp
   SUBMENU:=$(OTHER_MENU)
   TITLE:=PTP clock support