uci: update to latest Git head
authorPetr Štetiar <ynezz@true.cz>
Thu, 14 Nov 2019 21:31:02 +0000 (22:31 +0100)
committerPetr Štetiar <ynezz@true.cz>
Thu, 14 Nov 2019 21:53:31 +0000 (22:53 +0100)
 8dd50da20de0 lua: fix error handling
 a2cab3b088a2 ucimap: fix possible use of memory after it is freed
 9cf978bc7964 delta: prevent possible null pointer use
 7736f497d2d9 cli: remove unused variable assigment
 39093f3b040d lua: fix memory leak in set method
 19ceff323f1e lua: fix memory leak in changes method
 18049a84fe40 tests: add cram based unit tests
 2b549cc050de lua: fix copy&paste in error string
 f5dd5217d627 cli: fix realloc issue spotted by cppcheck
 af59f86a0db9 iron out all extra compiler warnings
 1637d2918692 tests: shunit2: run all tests under Valgrind by default
 c1af73bfb023 cmake: enable extra compiler checks
 be69504e3666 cmake: build Lua module only if enabled
 38a2f12ec5ab tests: shunit2: fix issues reported by shellcheck
 266fc9e94c1e add initial GitLab CI support
 17d6144a49c6 tests: shunit2: make it working under CMake
 a6e8bbefd860 cmake: add unit testing option and shunit2 tests
 0ca93fec701a test: move shunit2 tests under standalone subdirectory

Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/system/uci/Makefile

index d3169e01faac64b35faaf26a27231e28f2e36baf..dd08c43d299d1b689456fcede25268bacd2aa0de 100644 (file)
@@ -13,9 +13,9 @@ PKG_RELEASE:=3
 
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/uci.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE=2019-11-08
-PKG_SOURCE_VERSION:=fc417e808087f96466d9ce18819e16476af9527b
-PKG_MIRROR_HASH:=9d9f4756633e4b011ae68138793723c6443d0d81c7f626580881dc0cae77eceb
+PKG_SOURCE_DATE=2019-11-14
+PKG_SOURCE_VERSION:=8dd50da20de0ece65118b2b4b71f8df8ac3a1f6d
+PKG_MIRROR_HASH:=6c74d7dc777a64fd833c207fb7c7107f55d7b42ba7184ebaef5fc34f686c4a25
 
 PKG_LICENSE:=LGPL-2.1
 PKG_LICENSE_FILES:=