realtek: cleanup package selection
authorJohn Crispin <john@phrozen.org>
Sat, 28 Nov 2020 10:50:43 +0000 (11:50 +0100)
committerJohn Crispin <john@phrozen.org>
Wed, 2 Dec 2020 06:53:52 +0000 (07:53 +0100)
Signed-off-by: John Crispin <john@phrozen.org>
target/linux/realtek/Makefile
target/linux/realtek/image/Makefile

index 98fcaf3968de6ca19a3c3ec14564770620eda033..02eefe26fb748b76e1dbfa82e4bdbf9b6438eeb7 100644 (file)
@@ -22,6 +22,7 @@ include $(INCLUDE_DIR)/target.mk
 FEATURES := $(filter-out mips16,$(FEATURES))
 
 DEFAULT_PACKAGES += uboot-envtools ethtool kmod-gpio-button-hotplug \
-       dnsmasq firewall ip6tables iptables odhcp6c odhcpd-ipv6only
+       dnsmasq firewall ip6tables iptables odhcp6c odhcpd-ipv6only \
+       ip-full ip-bridge tc
 
 $(eval $(call BuildTarget))
index 4e9dbc350de63b8233e50726722bc42336a305fa..51356b35181a8bf6d9cf41597abdef7d5898d29b 100644 (file)
@@ -26,7 +26,6 @@ define Device/allnet_all-sg8208m
   DEVICE_MODEL := ALL-SG8208M
   UIMAGE_MAGIC := 0x00000006
   UIMAGE_NAME := 2.2.2.0
-  DEVICE_PACKAGES := ip-full ip-bridge kmod-gpio-button-hotplug tc
 endef
 TARGET_DEVICES += allnet_all-sg8208m
 
@@ -34,7 +33,6 @@ define Device/d-link_dgs-1210
   SOC := rtl8382
   IMAGE_SIZE := 13824k
   DEVICE_VENDOR := D-Link
-  DEVICE_PACKAGES := ip-full ip-bridge ethtool tc
 endef
 
 define Device/d-link_dgs-1210-10p
@@ -64,7 +62,6 @@ define Device/netgear_gs110tpp-v1
   DEVICE_VENDOR := NETGEAR
   DEVICE_MODEL := GS110TP
   DEVICE_VARIANT := v1
-  DEVICE_PACKAGES := ip-full ip-bridge ethtool tc
 endef
 TARGET_DEVICES += netgear_gs110tpp-v1