tools/fakeroot: fix build on macOS with recent Xcode versions
authorFelix Fietkau <nbd@nbd.name>
Sat, 14 Nov 2020 10:57:23 +0000 (11:57 +0100)
committerFelix Fietkau <nbd@nbd.name>
Sat, 14 Nov 2020 13:48:30 +0000 (14:48 +0100)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
tools/fakeroot/patches/100-portability.patch

index 3835a7792bd1bcc9a6831d15073d9498407cea52..5713c9e3fe86f1967d1b29e0ea79c49441335647 100644 (file)
@@ -25,7 +25,7 @@
  #ifdef HAVE_SYS_ACL_H
  #include <sys/acl.h>
  #endif /* HAVE_SYS_ACL_H */
-@@ -1894,7 +1901,7 @@ ssize_t fremovexattr(int fd, const char
+@@ -1894,7 +1901,7 @@ ssize_t fremovexattr(int fd, const char 
  }
  #endif /* HAVE_FREMOVEXATTR */
  
      if(argname){
          print "static __inline__ " ret " next_" name, argtype " __attribute__((always_inline));" > tmpffile;
          print "static __inline__ " ret " next_" name, argtype " {" > tmpffile;
+--- a/configure.ac
++++ b/configure.ac
+@@ -110,6 +110,7 @@ for first in size_t int; do
+ #include <sys/types.h>
+ #endif
+ #include <unistd.h>
++#include <stdio.h>
+ #ifdef HAVE_GRP_H
+ #include <grp.h>
+ #endif
+--- a/configure
++++ b/configure
+@@ -12847,6 +12847,7 @@ for first in size_t int; do
+ #include <sys/types.h>
+ #endif
+ #include <unistd.h>
++#include <stdio.h>
+ #ifdef HAVE_GRP_H
+ #include <grp.h>
+ #endif