imx6: image: increase max ubifs file-system size
authorTim Harvey <tharvey@gateworks.com>
Thu, 28 May 2020 13:57:05 +0000 (06:57 -0700)
committerPetr Štetiar <ynezz@true.cz>
Wed, 3 Jun 2020 14:49:28 +0000 (16:49 +0200)
The latest 2GiB NAND flash parts used by Gateworks ventana are 2K page-size.

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
target/linux/imx6/image/Makefile

index 232dc4225fab45853622da90701ac93f8574202f..2c9d03c039cb462f83c988075fb223a52fda924b 100644 (file)
@@ -35,7 +35,7 @@ define Build/boot-overlay
 
        $(STAGING_DIR_HOST)/bin/mkfs.ubifs \
                --space-fixup --compr=zlib --squash-uids \
-               $(MKUBIFS_OPTS) -c 8124 \
+               $(MKUBIFS_OPTS) -c 16248 \
                -o $@.boot.ubifs -d $@.boot
 
        $(TAR) -C $@.boot -cf $@.boot.tar .