linux-firmware: ibt-firmware: install sfi/ddc files for AX210 card
authorMathew McBride <matt@traverse.com.au>
Tue, 27 Jun 2023 01:23:40 +0000 (01:23 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 1 Jul 2023 09:57:33 +0000 (11:57 +0200)
When using an Intel AX210 card, the Bluetooth hci interface failed
to start due to a missing "ibt-0041-0041.sfi" file.

Bluetooth: hci0: Failed to load Intel firmware file intel/ibt-0041-0041.sfi (-2)

A device specific configuration file (DDC) is also required:
Bluetooth: hci0: Found device firmware: intel/ibt-0041-0041.sfi
Bluetooth: hci0: Waiting for firmware download to complete
...
Bluetooth: hci0: Found Intel DDC parameters: intel/ibt-0041-0041.ddc
Bluetooth: hci0: Applying Intel DDC parameters completed
Bluetooth: hci0: Firmware timestamp 2023.13 buildtype 1 build 62562

Fixes: #8558
Signed-off-by: Mathew McBride <matt@traverse.com.au>
package/firmware/linux-firmware/Makefile
package/firmware/linux-firmware/intel.mk

index bed11fdbe1f559cfe6337e420ec0ab8f39cac017..63259cae36abd0f95cb173497f0a8a56a5699b18 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=linux-firmware
 PKG_VERSION:=20230515
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=@KERNEL/linux/kernel/firmware
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
index 97694572b0bbceec6cba380ec2fb9c1cb0e325d3..23b58358b4eb7f18d60d2e910324dd5274222d5d 100644 (file)
@@ -3,6 +3,8 @@ define Package/ibt-firmware/install
        $(INSTALL_DIR) $(1)/lib/firmware/intel
        $(CP) \
                $(PKG_BUILD_DIR)/intel/*.bseq \
+               $(PKG_BUILD_DIR)/intel/ibt*.sfi \
+               $(PKG_BUILD_DIR)/intel/ibt*.ddc \
                $(1)/lib/firmware/intel
 endef
 $(eval $(call BuildPackage,ibt-firmware))