lantiq: Fix build after kernel 5.15.150
authorHauke Mehrtens <hauke@hauke-m.de>
Fri, 8 Mar 2024 13:43:08 +0000 (14:43 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 8 Mar 2024 13:49:09 +0000 (14:49 +0100)
This fixes the following compile problem:
````
  CC      arch/mips/kernel/vpe-mt.o
arch/mips/kernel/vpe-mt.c: In function 'vpe_run':
arch/mips/kernel/vpe-mt.c:32:23: error: unused variable 'physical_memsize' [-Werror=unused-variable]
   32 |         unsigned long physical_memsize = 0L;
      |                       ^~~~~~~~~~~~~~~~
cc1: all warnings being treated as errors
make[6]: *** [scripts/Makefile.build:289: arch/mips/kernel/vpe-mt.o] Error 1
````

physical_memsize was removed from upstream kernel, see:
https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-5.15.y&id=5b4f6c5ff65c8551018ccea40c569afd759734c0

Fixes: 387fde0da0e8 ("kernel: bump 5.15 to 5.15.150")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/lantiq/patches-5.15/0152-lantiq-VPE.patch
target/linux/lantiq/patches-5.15/0155-lantiq-VPE-nosmp.patch

index 00917331c214a79a3f78435896d98fb0f0e15d9f..2395261ff1a5d0301aac21b9c7e14354265355bd 100644 (file)
@@ -67,15 +67,7 @@ Signed-off-by: Stefan Koch <stefan.koch10@gmail.com>
  #endif /* _ASM_VPE_H */
 --- a/arch/mips/kernel/vpe-mt.c
 +++ b/arch/mips/kernel/vpe-mt.c
-@@ -29,6 +29,7 @@ int vpe_run(struct vpe *v)
-       struct vpe_notifications *notifier;
-       unsigned int vpeflags;
-       struct tc *t;
-+      unsigned long physical_memsize = 0L;
-       /* check we are the Master VPE */
-       local_irq_save(flags);
-@@ -415,6 +416,8 @@ int __init vpe_module_init(void)
+@@ -415,6 +415,8 @@ int __init vpe_module_init(void)
                        }
  
                        v->ntcs = hw_tcs - aprp_cpu_index();
@@ -84,7 +76,7 @@ Signed-off-by: Stefan Koch <stefan.koch10@gmail.com>
  
                        /* add the tc to the list of this vpe's tc's. */
                        list_add(&t->tc, &v->tc);
-@@ -518,3 +521,47 @@ void __exit vpe_module_exit(void)
+@@ -518,3 +520,47 @@ void __exit vpe_module_exit(void)
                        release_vpe(v);
        }
  }
index 015acabcfe1ec992df9db8c1a179f17c8782f7db..6426ee717ba342bd5e3eba50245a03d7938380a9 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Stefan Koch <stefan.koch10@gmail.com>
 
 --- a/arch/mips/kernel/vpe-mt.c
 +++ b/arch/mips/kernel/vpe-mt.c
-@@ -131,7 +131,10 @@ int vpe_run(struct vpe *v)
+@@ -130,7 +130,10 @@ int vpe_run(struct vpe *v)
         * kernels need to turn it on, even if that wasn't the pre-dvpe() state.
         */
  #ifdef CONFIG_SMP