sunxi: 6.6: refresh patches
authorZoltan HERPAI <wigyori@uid0.hu>
Wed, 17 Apr 2024 11:45:49 +0000 (13:45 +0200)
committerZoltan HERPAI <wigyori@uid0.hu>
Thu, 25 Apr 2024 14:34:25 +0000 (16:34 +0200)
Refresh kernel patches.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
target/linux/sunxi/patches-6.6/009-v6.9-soc-sunxi-sram-export-register-0-for-THS-on-H616.patch
target/linux/sunxi/patches-6.6/010-v6.8-thermal-drivers-sun8i-Add-D1-T113s-THS-controller-support.patch
target/linux/sunxi/patches-6.6/012-v6.9-thermal-drivers-sun8i-Extend-H6-calibration-to-support-4.patch
target/linux/sunxi/patches-6.6/013-v6.9-thermal-drivers-sun8i-Add-SRAM-register-access-code.patch
target/linux/sunxi/patches-6.6/014-v6.9-thermal-drivers-sun8i-Add-support-for-H616-THS-controller.patch
target/linux/sunxi/patches-6.6/015-v6.9-thermal-drivers-sun8i-Dont-fail-probe-due-to-zone-registra.patch
target/linux/sunxi/patches-6.6/301-orangepi_pc2_usb_otg_to_host_key_power.patch
target/linux/sunxi/patches-6.6/410-sunxi-add-bananapi-p2-zero.patch

index 3453e2aa5330ffba554f0da9e6bcfd54a056290d..5f9cb0273aecb021c6a81af358c606704d523e58 100644 (file)
@@ -37,7 +37,7 @@ Link: https://lore.kernel.org/r/20240219153639.179814-2-andre.przywara@arm.com
 
 --- a/drivers/soc/sunxi/sunxi_sram.c
 +++ b/drivers/soc/sunxi/sunxi_sram.c
-@@ -284,6 +284,7 @@ EXPORT_SYMBOL(sunxi_sram_release);
+@@ -287,6 +287,7 @@ EXPORT_SYMBOL(sunxi_sram_release);
  struct sunxi_sramc_variant {
        int num_emac_clocks;
        bool has_ldo_ctrl;
@@ -45,7 +45,7 @@ Link: https://lore.kernel.org/r/20240219153639.179814-2-andre.przywara@arm.com
  };
  
  static const struct sunxi_sramc_variant sun4i_a10_sramc_variant = {
-@@ -305,8 +306,10 @@ static const struct sunxi_sramc_variant
+@@ -308,8 +309,10 @@ static const struct sunxi_sramc_variant
  
  static const struct sunxi_sramc_variant sun50i_h616_sramc_variant = {
        .num_emac_clocks = 2,
@@ -56,7 +56,7 @@ Link: https://lore.kernel.org/r/20240219153639.179814-2-andre.przywara@arm.com
  #define SUNXI_SRAM_EMAC_CLOCK_REG     0x30
  #define SUNXI_SYS_LDO_CTRL_REG                0x150
  
-@@ -315,6 +318,8 @@ static bool sunxi_sram_regmap_accessible
+@@ -318,6 +321,8 @@ static bool sunxi_sram_regmap_accessible
  {
        const struct sunxi_sramc_variant *variant = dev_get_drvdata(dev);
  
@@ -65,7 +65,7 @@ Link: https://lore.kernel.org/r/20240219153639.179814-2-andre.przywara@arm.com
        if (reg >= SUNXI_SRAM_EMAC_CLOCK_REG &&
            reg <  SUNXI_SRAM_EMAC_CLOCK_REG + variant->num_emac_clocks * 4)
                return true;
-@@ -324,6 +329,20 @@ static bool sunxi_sram_regmap_accessible
+@@ -327,6 +332,20 @@ static bool sunxi_sram_regmap_accessible
        return false;
  }
  
@@ -86,7 +86,7 @@ Link: https://lore.kernel.org/r/20240219153639.179814-2-andre.przywara@arm.com
  static struct regmap_config sunxi_sram_regmap_config = {
        .reg_bits       = 32,
        .val_bits       = 32,
-@@ -333,6 +352,9 @@ static struct regmap_config sunxi_sram_r
+@@ -336,6 +355,9 @@ static struct regmap_config sunxi_sram_r
        /* other devices have no business accessing other registers */
        .readable_reg   = sunxi_sram_regmap_accessible_reg,
        .writeable_reg  = sunxi_sram_regmap_accessible_reg,
index 8b199891184fef085b3d6fa4bb7e11f07964a4b0..66f576eb386ada6fe93ecd316929b16671835a97 100644 (file)
@@ -18,7 +18,7 @@ Link: https://lore.kernel.org/r/20231217210629.131486-3-bigunclemax@gmail.com
 
 --- a/drivers/thermal/sun8i_thermal.c
 +++ b/drivers/thermal/sun8i_thermal.c
-@@ -610,6 +610,18 @@ static const struct ths_thermal_chip sun
+@@ -606,6 +606,18 @@ static const struct ths_thermal_chip sun
        .calc_temp = sun8i_ths_calc_temp,
  };
  
@@ -37,7 +37,7 @@ Link: https://lore.kernel.org/r/20231217210629.131486-3-bigunclemax@gmail.com
  static const struct of_device_id of_ths_match[] = {
        { .compatible = "allwinner,sun8i-a83t-ths", .data = &sun8i_a83t_ths },
        { .compatible = "allwinner,sun8i-h3-ths", .data = &sun8i_h3_ths },
-@@ -618,6 +630,7 @@ static const struct of_device_id of_ths_
+@@ -614,6 +626,7 @@ static const struct of_device_id of_ths_
        { .compatible = "allwinner,sun50i-a100-ths", .data = &sun50i_a100_ths },
        { .compatible = "allwinner,sun50i-h5-ths", .data = &sun50i_h5_ths },
        { .compatible = "allwinner,sun50i-h6-ths", .data = &sun50i_h6_ths },
index 3d01a507fac3956b915154ad886c58f89643f3f4..a0dbad48c9329c53f3d4d92cfd3d1782a2664fa5 100644 (file)
@@ -25,7 +25,7 @@ Link: https://lore.kernel.org/r/20240219153639.179814-5-andre.przywara@arm.com
 
 --- a/drivers/thermal/sun8i_thermal.c
 +++ b/drivers/thermal/sun8i_thermal.c
-@@ -224,16 +224,21 @@ static int sun50i_h6_ths_calibrate(struc
+@@ -222,16 +222,21 @@ static int sun50i_h6_ths_calibrate(struc
        struct device *dev = tmdev->dev;
        int i, ft_temp;
  
@@ -52,7 +52,7 @@ Link: https://lore.kernel.org/r/20240219153639.179814-5-andre.przywara@arm.com
         *
         * The calibration data on the H6 is the ambient temperature and
         * sensor values that are filled during the factory test stage.
-@@ -246,9 +251,16 @@ static int sun50i_h6_ths_calibrate(struc
+@@ -244,9 +249,16 @@ static int sun50i_h6_ths_calibrate(struc
        ft_temp = (caldata[0] & FT_TEMP_MASK) * 100;
  
        for (i = 0; i < tmdev->chip->sensor_num; i++) {
index 6db1e32cfb5a306a925f9f16f46de5f895fbeb5f..9b5e9d374fdef9ea85dc83ec751ba283c17ca1c3 100644 (file)
@@ -28,12 +28,12 @@ Link: https://lore.kernel.org/r/20240219153639.179814-6-andre.przywara@arm.com
 @@ -15,6 +15,7 @@
  #include <linux/module.h>
  #include <linux/nvmem-consumer.h>
- #include <linux/of_device.h>
+ #include <linux/of.h>
 +#include <linux/of_platform.h>
  #include <linux/platform_device.h>
  #include <linux/regmap.h>
  #include <linux/reset.h>
-@@ -68,6 +69,7 @@ struct tsensor {
+@@ -66,6 +67,7 @@ struct tsensor {
  struct ths_thermal_chip {
        bool            has_mod_clk;
        bool            has_bus_clk_reset;
@@ -41,7 +41,7 @@ Link: https://lore.kernel.org/r/20240219153639.179814-6-andre.przywara@arm.com
        int             sensor_num;
        int             offset;
        int             scale;
-@@ -85,12 +87,16 @@ struct ths_device {
+@@ -83,12 +85,16 @@ struct ths_device {
        const struct ths_thermal_chip           *chip;
        struct device                           *dev;
        struct regmap                           *regmap;
index e743d344c6e97daa2ba2af2c67780846ba71acce..187bc0dd7b0b17b6eb124d9a885626c6cb392806 100644 (file)
@@ -19,7 +19,7 @@ Link: https://lore.kernel.org/r/20240219153639.179814-7-andre.przywara@arm.com
 
 --- a/drivers/thermal/sun8i_thermal.c
 +++ b/drivers/thermal/sun8i_thermal.c
-@@ -688,6 +688,20 @@ static const struct ths_thermal_chip sun
+@@ -684,6 +684,20 @@ static const struct ths_thermal_chip sun
        .calc_temp = sun8i_ths_calc_temp,
  };
  
@@ -40,7 +40,7 @@ Link: https://lore.kernel.org/r/20240219153639.179814-7-andre.przywara@arm.com
  static const struct of_device_id of_ths_match[] = {
        { .compatible = "allwinner,sun8i-a83t-ths", .data = &sun8i_a83t_ths },
        { .compatible = "allwinner,sun8i-h3-ths", .data = &sun8i_h3_ths },
-@@ -697,6 +711,7 @@ static const struct of_device_id of_ths_
+@@ -693,6 +707,7 @@ static const struct of_device_id of_ths_
        { .compatible = "allwinner,sun50i-h5-ths", .data = &sun50i_h5_ths },
        { .compatible = "allwinner,sun50i-h6-ths", .data = &sun50i_h6_ths },
        { .compatible = "allwinner,sun20i-d1-ths", .data = &sun20i_d1_ths },
index 384bf55084f307509f8eaa4adc5d49e972e7e171..dd18cd953c3fd6069f895dee4a1d0c2904b1cb19 100644 (file)
@@ -36,7 +36,7 @@ Link: https://lore.kernel.org/r/20240123-thermal-sun8i-registration-v3-1-3e5771b
 
 --- a/drivers/thermal/sun8i_thermal.c
 +++ b/drivers/thermal/sun8i_thermal.c
-@@ -197,6 +197,9 @@ static irqreturn_t sun8i_irq_thread(int
+@@ -195,6 +195,9 @@ static irqreturn_t sun8i_irq_thread(int
        int i;
  
        for_each_set_bit(i, &irq_bitmap, tmdev->chip->sensor_num) {
@@ -64,5 +64,5 @@ Link: https://lore.kernel.org/r/20240123-thermal-sun8i-registration-v3-1-3e5771b
 +                      continue;
 +              }
  
-               if (devm_thermal_add_hwmon_sysfs(tmdev->sensor[i].tzd))
-                       dev_warn(tmdev->dev,
+               devm_thermal_add_hwmon_sysfs(tmdev->dev, tmdev->sensor[i].tzd);
+       }
index 2c5ccd7d96deb0c8899e270db25c73e3d739fe0f..eea47737fa587a81394be94379406109620dd035 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm64/boot/dts/allwinner/sun50i-h5-orangepi-pc2.dts
 +++ b/arch/arm64/boot/dts/allwinner/sun50i-h5-orangepi-pc2.dts
-@@ -59,7 +59,7 @@
+@@ -60,7 +60,7 @@
  
                key-sw4 {
                        label = "sw4";
@@ -9,7 +9,7 @@
                        gpios = <&r_pio 0 3 GPIO_ACTIVE_LOW>;
                        wakeup-source;
                };
-@@ -220,7 +220,7 @@
+@@ -221,7 +221,7 @@
  };
  
  &usb_otg {
index 5b8dd170c59ffb501038d90ba0cbfc884dc53373..01044fef4950bd0b1d1fda7a0748e6be13bf671b 100644 (file)
@@ -1,6 +1,6 @@
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
-@@ -1352,6 +1352,7 @@ dtb-$(CONFIG_MACH_SUN8I) += \
+--- a/arch/arm/boot/dts/allwinner/Makefile
++++ b/arch/arm/boot/dts/allwinner/Makefile
+@@ -280,6 +280,7 @@ dtb-$(CONFIG_MACH_SUN8I) += \
        sun8i-a83t-cubietruck-plus.dtb \
        sun8i-a83t-tbs-a711.dtb \
        sun8i-h2-plus-bananapi-m2-zero.dtb \
@@ -9,7 +9,7 @@
        sun8i-h2-plus-orangepi-r1.dtb \
        sun8i-h2-plus-orangepi-zero.dtb \
 --- /dev/null
-+++ b/arch/arm/boot/dts/sun8i-h2-plus-bananapi-p2-zero.dts
++++ b/arch/arm/boot/dts/allwinner/sun8i-h2-plus-bananapi-p2-zero.dts
 @@ -0,0 +1,279 @@
 +// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
 +/*