kernel: bump to 4.14.243
authorDavid Bauer <mail@david-bauer.net>
Thu, 12 Aug 2021 21:33:05 +0000 (23:33 +0200)
committerDavid Bauer <mail@david-bauer.net>
Sat, 14 Aug 2021 12:49:18 +0000 (14:49 +0200)
Compile-tested: x86-64
Run-tested: x86-64

Signed-off-by: David Bauer <mail@david-bauer.net>
include/kernel-version.mk
target/linux/generic/backport-4.14/320-v4.16-netfilter-nf_conntrack-add-IPS_OFFLOAD-status-bit.patch
target/linux/generic/backport-4.14/370-netfilter-nf_flow_table-fix-offloaded-connection-tim.patch
target/linux/generic/hack-4.14/901-debloat_sock_diag.patch
target/linux/generic/pending-4.14/680-NET-skip-GRO-for-foreign-MAC-addresses.patch
target/linux/layerscape/patches-4.14/202-core-linux-support-layerscape.patch

index 8e4032874612add2f9ba1d8adf6e4cc9005f0232..f287885ba969533c3a573b30d2852b3dff8adcf0 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .241
+LINUX_VERSION-4.14 = .243
 
-LINUX_KERNEL_HASH-4.14.241 = b5bb04bb70154ba27a08bc1c067eb7c08fc3d513da58e6a33d6645b3a1889f7d
+LINUX_KERNEL_HASH-4.14.243 = 7f235d454d703112e86574150652807f42abead92f3837da32ea86b4f148b371
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 03c1deec707b226c9ed4571976a0012b2cc77301..771d515b2d65c7730f31935a265d9e12467e85af 100644 (file)
@@ -47,7 +47,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  };
 --- a/net/netfilter/nf_conntrack_core.c
 +++ b/net/netfilter/nf_conntrack_core.c
-@@ -975,6 +975,9 @@ static unsigned int early_drop_list(stru
+@@ -980,6 +980,9 @@ static unsigned int early_drop_list(stru
        hlist_nulls_for_each_entry_rcu(h, n, head, hnnode) {
                tmp = nf_ct_tuplehash_to_ctrack(h);
  
@@ -57,7 +57,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
                if (nf_ct_is_expired(tmp)) {
                        nf_ct_gc_expired(tmp);
                        continue;
-@@ -1052,6 +1055,18 @@ static bool gc_worker_can_early_drop(con
+@@ -1057,6 +1060,18 @@ static bool gc_worker_can_early_drop(con
        return false;
  }
  
@@ -76,7 +76,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  static void gc_worker(struct work_struct *work)
  {
        unsigned int min_interval = max(HZ / GC_MAX_BUCKETS_DIV, 1u);
-@@ -1088,6 +1103,11 @@ static void gc_worker(struct work_struct
+@@ -1093,6 +1108,11 @@ static void gc_worker(struct work_struct
                        tmp = nf_ct_tuplehash_to_ctrack(h);
  
                        scanned++;
index 230c90f7c58881cb42709cdc4306dad9817cbbab..2776e6e86183892e953130630a15b4e38eca0e73 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/net/netfilter/nf_conntrack_core.c
 +++ b/net/netfilter/nf_conntrack_core.c
-@@ -1055,18 +1055,6 @@ static bool gc_worker_can_early_drop(con
+@@ -1060,18 +1060,6 @@ static bool gc_worker_can_early_drop(con
        return false;
  }
  
@@ -40,7 +40,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static void gc_worker(struct work_struct *work)
  {
        unsigned int min_interval = max(HZ / GC_MAX_BUCKETS_DIV, 1u);
-@@ -1103,10 +1091,8 @@ static void gc_worker(struct work_struct
+@@ -1108,10 +1096,8 @@ static void gc_worker(struct work_struct
                        tmp = nf_ct_tuplehash_to_ctrack(h);
  
                        scanned++;
index 2f2b8eb70532cd692fe9c5be19aceb223bc8d9fb..e6b098344cd2be3a8dd82698a683345cbf4fb015 100644 (file)
@@ -126,7 +126,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
          Support for PF_PACKET sockets monitoring interface used by the ss tool.
 --- a/net/unix/Kconfig
 +++ b/net/unix/Kconfig
-@@ -22,6 +22,7 @@ config UNIX
+@@ -27,6 +27,7 @@ config UNIX_SCM
  config UNIX_DIAG
        tristate "UNIX: socket monitoring interface"
        depends on UNIX
index ab05eda4eba4c8d3d022e249d0d3b30f8e393ace..4049b373e791b1838493b1aab0e508e1c17018e2 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        __u16                   tc_index;       /* traffic control index */
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
-@@ -4802,6 +4802,9 @@ static enum gro_result dev_gro_receive(s
+@@ -4803,6 +4803,9 @@ static enum gro_result dev_gro_receive(s
        enum gro_result ret;
        int grow;
  
@@ -42,7 +42,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (netif_elide_gro(skb->dev))
                goto normal;
  
-@@ -6287,6 +6290,48 @@ static void __netdev_adjacent_dev_unlink
+@@ -6288,6 +6291,48 @@ static void __netdev_adjacent_dev_unlink
                                           &upper_dev->adj_list.lower);
  }
  
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static int __netdev_upper_dev_link(struct net_device *dev,
                                   struct net_device *upper_dev, bool master,
                                   void *upper_priv, void *upper_info)
-@@ -6325,6 +6370,7 @@ static int __netdev_upper_dev_link(struc
+@@ -6326,6 +6371,7 @@ static int __netdev_upper_dev_link(struc
        if (ret)
                return ret;
  
@@ -99,7 +99,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        ret = call_netdevice_notifiers_info(NETDEV_CHANGEUPPER, dev,
                                            &changeupper_info.info);
        ret = notifier_to_errno(ret);
-@@ -6402,6 +6448,7 @@ void netdev_upper_dev_unlink(struct net_
+@@ -6403,6 +6449,7 @@ void netdev_upper_dev_unlink(struct net_
  
        __netdev_adjacent_dev_unlink_neighbour(dev, upper_dev);
  
@@ -107,7 +107,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        call_netdevice_notifiers_info(NETDEV_CHANGEUPPER, dev,
                                      &changeupper_info.info);
  }
-@@ -6966,6 +7013,7 @@ int dev_set_mac_address(struct net_devic
+@@ -6967,6 +7014,7 @@ int dev_set_mac_address(struct net_devic
        if (err)
                return err;
        dev->addr_assign_type = NET_ADDR_SET;
index eb412af778a127d9c3d658d31f0253cf1db8da73..083a518bba7718a8a09bf3e5d31b5616f378b703 100644 (file)
@@ -580,7 +580,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  void  __kfree_skb(struct sk_buff *skb);
  extern struct kmem_cache *skbuff_head_cache;
  
-@@ -3344,6 +3345,7 @@ static inline void skb_free_datagram_loc
+@@ -3353,6 +3354,7 @@ static inline void skb_free_datagram_loc
  }
  int skb_kill_datagram(struct sock *sk, struct sk_buff *skb, unsigned int flags);
  int skb_copy_bits(const struct sk_buff *skb, int offset, void *to, int len);
@@ -713,7 +713,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  }
  
  #ifdef CONFIG_NET_INGRESS
-@@ -6346,7 +6347,15 @@ static int __netdev_upper_dev_link(struc
+@@ -6347,7 +6348,15 @@ static int __netdev_upper_dev_link(struc
                                   struct net_device *upper_dev, bool master,
                                   void *upper_priv, void *upper_info)
  {
@@ -730,7 +730,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        int ret = 0;
  
        ASSERT_RTNL();
-@@ -6364,12 +6373,7 @@ static int __netdev_upper_dev_link(struc
+@@ -6365,12 +6374,7 @@ static int __netdev_upper_dev_link(struc
        if (master && netdev_master_upper_dev_get(dev))
                return -EBUSY;
  
@@ -744,7 +744,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                                            &changeupper_info.info);
        ret = notifier_to_errno(ret);
        if (ret)
-@@ -6381,7 +6385,7 @@ static int __netdev_upper_dev_link(struc
+@@ -6382,7 +6386,7 @@ static int __netdev_upper_dev_link(struc
                return ret;
  
        netdev_update_addr_mask(dev);
@@ -753,7 +753,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                                            &changeupper_info.info);
        ret = notifier_to_errno(ret);
        if (ret)
-@@ -6445,21 +6449,25 @@ EXPORT_SYMBOL(netdev_master_upper_dev_li
+@@ -6446,21 +6450,25 @@ EXPORT_SYMBOL(netdev_master_upper_dev_li
  void netdev_upper_dev_unlink(struct net_device *dev,
                             struct net_device *upper_dev)
  {
@@ -784,7 +784,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                                      &changeupper_info.info);
  }
  EXPORT_SYMBOL(netdev_upper_dev_unlink);
-@@ -6475,11 +6483,13 @@ EXPORT_SYMBOL(netdev_upper_dev_unlink);
+@@ -6476,11 +6484,13 @@ EXPORT_SYMBOL(netdev_upper_dev_unlink);
  void netdev_bonding_info_change(struct net_device *dev,
                                struct netdev_bonding_info *bonding_info)
  {
@@ -800,7 +800,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                                      &info.info);
  }
  EXPORT_SYMBOL(netdev_bonding_info_change);
-@@ -6605,11 +6615,13 @@ EXPORT_SYMBOL(dev_get_nest_level);
+@@ -6606,11 +6616,13 @@ EXPORT_SYMBOL(dev_get_nest_level);
  void netdev_lower_state_changed(struct net_device *lower_dev,
                                void *lower_state_info)
  {
@@ -816,7 +816,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                                      &changelowerstate_info.info);
  }
  EXPORT_SYMBOL(netdev_lower_state_changed);
-@@ -6900,11 +6912,14 @@ void __dev_notify_flags(struct net_devic
+@@ -6901,11 +6913,14 @@ void __dev_notify_flags(struct net_devic
  
        if (dev->flags & IFF_UP &&
            (changes & ~(IFF_UP | IFF_PROMISC | IFF_ALLMULTI | IFF_VOLATILE))) {