kernel: bump 4.14 to 4.14.254
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 6 Nov 2021 18:43:08 +0000 (18:43 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 7 Nov 2021 18:49:50 +0000 (19:49 +0100)
All updated automatically.

Compile-tested on: malta/le, lantiq/xrx200
Runtime-tested on: malta/le, lantiq/xrx200

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
24 files changed:
include/kernel-version.mk
target/linux/apm821xx/patches-4.14/801-usb-xhci-add-firmware-loader-for-uPD720201-and-uPD72.patch
target/linux/apm821xx/patches-4.14/802-usb-xhci-force-msi-renesas-xhci.patch
target/linux/ar71xx/patches-4.14/950-add-boardinfo-platform-data.patch
target/linux/brcm2708/patches-4.14/950-0292-net-mdiobus-add-unlocked-accessors.patch
target/linux/generic/backport-4.14/025-tcp-allow-drivers-to-tweak-TSQ-logic.patch
target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
target/linux/generic/hack-4.14/220-gc_sections.patch
target/linux/generic/hack-4.14/901-debloat_sock_diag.patch
target/linux/generic/hack-4.14/902-debloat_proc.patch
target/linux/generic/pending-4.14/834-ledtrig-libata.patch
target/linux/ipq806x/patches-4.14/0060-HACK-arch-arm-force-ZRELADDR-on-arch-qcom.patch
target/linux/ipq806x/patches-4.14/0067-generic-Mangle-bootloader-s-kernel-arguments.patch
target/linux/lantiq/patches-4.14/0025-NET-MIPS-lantiq-adds-xrx200-net.patch
target/linux/layerscape/patches-4.14/801-sata-support-layerscape.patch
target/linux/layerscape/patches-4.14/807-usb-support-layerscape.patch
target/linux/layerscape/patches-4.14/819-sdhc-support-layerscape.patch
target/linux/mediatek/patches-4.14/0191-usb-xhci-allow-imod-interval-to-be-configurable.patch
target/linux/mvebu/patches-4.14/006-mvebu-Mangle-bootloader-s-kernel-arguments.patch
target/linux/mvebu/patches-4.14/524-PCI-aardvark-set-host-and-device-to-the-same-MAX-payload-size.patch
target/linux/mvebu/patches-4.14/527-PCI-aardvark-allow-to-specify-link-capability.patch
target/linux/oxnas/patches-4.14/996-generic-Mangle-bootloader-s-kernel-arguments.patch
target/linux/oxnas/patches-4.14/999-libata-hacks.patch
target/linux/ramips/patches-4.14/700-net-mdiobus-add-unlocked-accessors.patch

index 5230350d9b67ad5f1776c8314a63bca81ac8e2f2..2e1cff180cfa45ce9aae1631ea19468a7b42725f 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .248
+LINUX_VERSION-4.14 = .254
 
-LINUX_KERNEL_HASH-4.14.248 = c993eecf5cc41acbd874fde56eecb87ac021df477defe3d8bd1d811548d3b654
+LINUX_KERNEL_HASH-4.14.254 = dfd95c1bc3af5b0e57e53608f8356037510b19cb55cac520e43c3d499ea60d46
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 6443057b0f649d17d239dd36f0d423369ef8665b..7efc437fa18e58bbf16e9841ca36a3daf7fce0ab 100644 (file)
@@ -44,7 +44,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
  
  #include "xhci.h"
  #include "xhci-trace.h"
-@@ -280,6 +282,458 @@ static void xhci_pme_acpi_rtd3_enable(st
+@@ -282,6 +284,458 @@ static void xhci_pme_acpi_rtd3_enable(st
  static void xhci_pme_acpi_rtd3_enable(struct pci_dev *dev) { }
  #endif /* CONFIG_ACPI */
  
@@ -503,7 +503,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
  /* called during probe() after chip reset completes */
  static int xhci_pci_setup(struct usb_hcd *hcd)
  {
-@@ -318,6 +772,22 @@ static int xhci_pci_probe(struct pci_dev
+@@ -320,6 +774,22 @@ static int xhci_pci_probe(struct pci_dev
        struct hc_driver *driver;
        struct usb_hcd *hcd;
  
@@ -526,7 +526,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
        driver = (struct hc_driver *)id->driver_data;
  
        /* For some HW implementation, a XHCI reset is just not enough... */
-@@ -379,6 +849,16 @@ static void xhci_pci_remove(struct pci_d
+@@ -381,6 +851,16 @@ static void xhci_pci_remove(struct pci_d
  {
        struct xhci_hcd *xhci;
  
index c8eb2b420ba562de884d0ee3addbfd7d90cc1252..bfc5fe8507e5ce4d72d6f2bfa344321f1c68c50b 100644 (file)
@@ -13,7 +13,7 @@ produce a noisy warning.
 
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -226,7 +226,7 @@ static void xhci_pci_quirks(struct devic
+@@ -228,7 +228,7 @@ static void xhci_pci_quirks(struct devic
                xhci->quirks |= XHCI_TRUST_TX_LENGTH;
        if (pdev->vendor == PCI_VENDOR_ID_RENESAS &&
                        pdev->device == 0x0015)
index 6b0d30002337756e80bd11f1b40cd6efcc0c0c65..5c76f6c92f82f1e7b96703b5daca7728dbbf778f 100644 (file)
@@ -26,7 +26,7 @@
  #endif /* __MDIO_BOARD_INFO_H */
 --- a/drivers/net/phy/mdio_bus.c
 +++ b/drivers/net/phy/mdio_bus.c
-@@ -456,6 +456,17 @@ void mdiobus_free(struct mii_bus *bus)
+@@ -463,6 +463,17 @@ void mdiobus_free(struct mii_bus *bus)
  }
  EXPORT_SYMBOL(mdiobus_free);
  
@@ -44,7 +44,7 @@
  /**
   * mdiobus_scan - scan a bus for MDIO devices.
   * @bus: mii_bus to scan
-@@ -471,6 +482,7 @@ EXPORT_SYMBOL(mdiobus_free);
+@@ -478,6 +489,7 @@ EXPORT_SYMBOL(mdiobus_free);
  struct phy_device *mdiobus_scan(struct mii_bus *bus, int addr)
  {
        struct phy_device *phydev;
@@ -52,7 +52,7 @@
        int err;
  
        phydev = get_phy_device(bus, addr, false);
-@@ -483,6 +495,12 @@ struct phy_device *mdiobus_scan(struct m
+@@ -490,6 +502,12 @@ struct phy_device *mdiobus_scan(struct m
         */
        of_mdiobus_link_mdiodev(bus, &phydev->mdio);
  
index 3bf86f612e86a2a2f6b3fed4e728261c7d3e9b6c..866f2643a80cec17ea2f8339cf450740f2a7a219 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/phy/mdio_bus.c
 +++ b/drivers/net/phy/mdio_bus.c
-@@ -494,6 +494,55 @@ struct phy_device *mdiobus_scan(struct m
+@@ -501,6 +501,55 @@ struct phy_device *mdiobus_scan(struct m
  EXPORT_SYMBOL(mdiobus_scan);
  
  /**
@@ -75,7 +75,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
   * mdiobus_read_nested - Nested version of the mdiobus_read function
   * @bus: the mii_bus struct
   * @addr: the phy address
-@@ -513,11 +562,9 @@ int mdiobus_read_nested(struct mii_bus *
+@@ -520,11 +569,9 @@ int mdiobus_read_nested(struct mii_bus *
        BUG_ON(in_interrupt());
  
        mutex_lock_nested(&bus->mdio_lock, MDIO_MUTEX_NESTED);
@@ -88,7 +88,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        return retval;
  }
  EXPORT_SYMBOL(mdiobus_read_nested);
-@@ -539,11 +586,9 @@ int mdiobus_read(struct mii_bus *bus, in
+@@ -546,11 +593,9 @@ int mdiobus_read(struct mii_bus *bus, in
        BUG_ON(in_interrupt());
  
        mutex_lock(&bus->mdio_lock);
@@ -101,7 +101,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        return retval;
  }
  EXPORT_SYMBOL(mdiobus_read);
-@@ -569,11 +614,9 @@ int mdiobus_write_nested(struct mii_bus
+@@ -576,11 +621,9 @@ int mdiobus_write_nested(struct mii_bus
        BUG_ON(in_interrupt());
  
        mutex_lock_nested(&bus->mdio_lock, MDIO_MUTEX_NESTED);
@@ -114,7 +114,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        return err;
  }
  EXPORT_SYMBOL(mdiobus_write_nested);
-@@ -596,11 +639,9 @@ int mdiobus_write(struct mii_bus *bus, i
+@@ -603,11 +646,9 @@ int mdiobus_write(struct mii_bus *bus, i
        BUG_ON(in_interrupt());
  
        mutex_lock(&bus->mdio_lock);
@@ -129,7 +129,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  EXPORT_SYMBOL(mdiobus_write);
 --- a/include/linux/mdio.h
 +++ b/include/linux/mdio.h
-@@ -257,6 +257,9 @@ static inline u16 ethtool_adv_to_mmd_eee
+@@ -260,6 +260,9 @@ static inline u16 ethtool_adv_to_mmd_eee
        return reg;
  }
  
index 6f018b9e4a85c618b9f2ec972808066f49f9d4c6..1bb30ab6ca5980f8039a90949e15ec8a8c0a4a78 100644 (file)
@@ -55,7 +55,7 @@ Cc: Kir Kolyshkin <kir@openvz.org>
        rwlock_t                sk_callback_lock;
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -2771,6 +2771,7 @@ void sock_init_data(struct socket *sock,
+@@ -2791,6 +2791,7 @@ void sock_init_data(struct socket *sock,
  
        sk->sk_max_pacing_rate = ~0U;
        sk->sk_pacing_rate = ~0U;
index 7fc129bb9a5ae41349431323d0c500fbcfba11dd..be733b6d1ff377796bf6257acb57d57173842b1f 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
 
 --- a/drivers/usb/serial/option.c
 +++ b/drivers/usb/serial/option.c
-@@ -2033,7 +2033,8 @@ static const struct usb_device_id option
+@@ -2048,7 +2048,8 @@ static const struct usb_device_id option
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },                   /* D-Link DWM-156 (variant) */
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },
index 0095b7983444483d7535c5b96f9a2031139db827..2605d7f78f36ee8caa5db3d1e59fe399355c8eed 100644 (file)
@@ -47,7 +47,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  CHECKFLAGS     += $(NOSTDINC_FLAGS)
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -91,6 +91,7 @@ config ARM
+@@ -92,6 +92,7 @@ config ARM
        select HAVE_UID16
        select HAVE_VIRT_CPU_ACCOUNTING_GEN
        select IRQ_FORCED_THREADING
index e6b098344cd2be3a8dd82698a683345cbf4fb015..978cf4cde1fa78df1c6ee62e4b8c6e4493a60624 100644 (file)
@@ -61,7 +61,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  struct dst_entry *__sk_dst_check(struct sock *sk, u32 cookie)
  {
        struct dst_entry *dst = __sk_dst_get(sk);
-@@ -1599,9 +1611,11 @@ void sk_destruct(struct sock *sk)
+@@ -1617,9 +1629,11 @@ void sk_destruct(struct sock *sk)
  
  static void __sk_free(struct sock *sk)
  {
index 8d02402498537336f031a7d21dad3ebe05a7d2b9..4c1018867dfe91e2c429e6b260d9f65dc1b6aadb 100644 (file)
@@ -327,7 +327,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -3410,6 +3410,8 @@ static __net_initdata struct pernet_oper
+@@ -3430,6 +3430,8 @@ static __net_initdata struct pernet_oper
  
  static int __init proto_init(void)
  {
index b025785ae15fae78a154900a2bd8101e9c8107ee..4de54e0a8b42c2576123c02c6eeb5672322cfbab 100644 (file)
@@ -65,7 +65,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
-@@ -5129,6 +5142,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -5157,6 +5170,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
                if (tag < 0)
                        return NULL;
        }
@@ -75,7 +75,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
        qc = __ata_qc_from_tag(ap, tag);
        qc->tag = tag;
-@@ -6032,6 +6048,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -6060,6 +6076,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -85,7 +85,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        ata_sff_port_init(ap);
  
        return ap;
-@@ -6053,6 +6072,12 @@ static void ata_host_release(struct devi
+@@ -6081,6 +6100,12 @@ static void ata_host_release(struct devi
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -98,7 +98,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -6499,7 +6524,23 @@ int ata_host_register(struct ata_host *h
+@@ -6527,7 +6552,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }
@@ -134,7 +134,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
  /*
   * Define if arch has non-standard setup.  This is a _PCI_ standard
-@@ -895,6 +898,12 @@ struct ata_port {
+@@ -896,6 +899,12 @@ struct ata_port {
  #ifdef CONFIG_ATA_ACPI
        struct ata_acpi_gtm     __acpi_init_gtm; /* use ata_acpi_init_gtm() */
  #endif
index 581761f58095d781e91488d7c953f88441134d4b..b8236d87ea27edc427cc0dfdd29ec50f0559e3c6 100644 (file)
@@ -33,7 +33,7 @@ Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -341,7 +341,7 @@ config ARCH_MULTIPLATFORM
+@@ -342,7 +342,7 @@ config ARCH_MULTIPLATFORM
        depends on MMU
        select ARM_HAS_SG_CHAIN
        select ARM_PATCH_PHYS_VIRT
index c977dd1001d74cbb736d426df1e17021fbbc1148..e2059e20e6a6eeff0e47e8e42370203435261fc8 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1936,6 +1936,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1937,6 +1937,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
          The command-line arguments provided by the boot loader will be
          appended to the the device tree bootargs property.
  
index 7eaf0b7b7bbf9273cbc6bc1199ede126b4d509cd..b32d154e322fb15f6c505da5a9297f8e6ede7580 100644 (file)
@@ -16,7 +16,7 @@ Subject: [PATCH 25/36] NET: MIPS: lantiq: adds xrx200-net
 
 --- a/drivers/net/ethernet/Kconfig
 +++ b/drivers/net/ethernet/Kconfig
-@@ -107,7 +107,13 @@ config LANTIQ_ETOP
+@@ -108,7 +108,13 @@ config LANTIQ_ETOP
        tristate "Lantiq SoC ETOP driver"
        depends on SOC_TYPE_XWAY
        ---help---
index 995a8a80821d781fb89438fc79fa1e1457f0549f..63eb4041303a182bf07bfb88cdfb10927e7646a3 100644 (file)
@@ -278,7 +278,7 @@ Signed-off-by: Tang Yuantian <andy.tang@nxp.com>
  #include "libata.h"
  #include "libata-transport.h"
  
-@@ -4118,6 +4119,8 @@ int sata_link_hardreset(struct ata_link
+@@ -4144,6 +4145,8 @@ int sata_link_hardreset(struct ata_link
         */
        ata_msleep(link->ap, 1);
  
index 6c9cdc3d6b134347126d5b64faa6b33ad29b0e24..16926efe93201951fdbd7d9896d5522ea7f1c9c5 100644 (file)
@@ -1289,7 +1289,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
                xhci->quirks |= XHCI_BROKEN_PORT_PED;
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
-@@ -2016,10 +2016,12 @@ static int finish_td(struct xhci_hcd *xh
+@@ -2022,10 +2022,12 @@ static int finish_td(struct xhci_hcd *xh
        union xhci_trb *ep_trb, struct xhci_transfer_event *event,
        struct xhci_virt_ep *ep, int *status)
  {
@@ -1302,7 +1302,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
        u32 trb_comp_code;
        int ep_index;
  
-@@ -2042,14 +2044,30 @@ static int finish_td(struct xhci_hcd *xh
+@@ -2048,14 +2050,30 @@ static int finish_td(struct xhci_hcd *xh
        if (trb_comp_code == COMP_STALL_ERROR ||
                xhci_requires_manual_halt_cleanup(xhci, ep_ctx,
                                                trb_comp_code)) {
index 583ca11751c2aa6c2c7f1b5ee7a596317b0c4eaa..746391a31f202aeee72878ac5745e8584f9adae9 100644 (file)
@@ -497,7 +497,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>
                .name = "sdhci-esdhc",
 --- a/drivers/mmc/host/sdhci.c
 +++ b/drivers/mmc/host/sdhci.c
-@@ -2152,7 +2152,7 @@ static void sdhci_send_tuning(struct sdh
+@@ -2158,7 +2158,7 @@ static void sdhci_send_tuning(struct sdh
  
  }
  
@@ -506,7 +506,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>
  {
        int i;
  
-@@ -2169,13 +2169,13 @@ static void __sdhci_execute_tuning(struc
+@@ -2175,13 +2175,13 @@ static void __sdhci_execute_tuning(struc
                        pr_debug("%s: Tuning timeout, falling back to fixed sampling clock\n",
                                 mmc_hostname(host->mmc));
                        sdhci_abort_tuning(host, opcode);
@@ -522,7 +522,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>
                        break;
                }
  
-@@ -2187,6 +2187,7 @@ static void __sdhci_execute_tuning(struc
+@@ -2193,6 +2193,7 @@ static void __sdhci_execute_tuning(struc
        pr_info("%s: Tuning failed, falling back to fixed sampling clock\n",
                mmc_hostname(host->mmc));
        sdhci_reset_tuning(host);
@@ -530,7 +530,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>
  }
  
  int sdhci_execute_tuning(struct mmc_host *mmc, u32 opcode)
-@@ -2248,7 +2249,7 @@ int sdhci_execute_tuning(struct mmc_host
+@@ -2254,7 +2255,7 @@ int sdhci_execute_tuning(struct mmc_host
  
        sdhci_start_tuning(host);
  
index 884c5008d5318f2e3c60491db25831f2efe6d7e5..91a645710bd41c9cdfd235489468abc6b18a15a8 100644 (file)
@@ -86,7 +86,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
        if (!xhci->shared_hcd) {
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -291,6 +291,9 @@ static int xhci_pci_setup(struct usb_hcd
+@@ -293,6 +293,9 @@ static int xhci_pci_setup(struct usb_hcd
        if (!xhci->sbrn)
                pci_read_config_byte(pdev, XHCI_SBRN_OFFSET, &xhci->sbrn);
  
index f9d902b4d988650d8276da205b8d28bbc8edf7e3..f81a3e53226cbcf96fb288951cac5b6b7638040f 100644 (file)
@@ -28,7 +28,7 @@ Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1936,6 +1936,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1937,6 +1937,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
          The command-line arguments provided by the boot loader will be
          appended to the the device tree bootargs property.
  
index 702e1158f11bb5c9f5adc7189bf0e15e8283dc36..ab643b776f00814bcc61a8d379e152f811f5d666 100644 (file)
@@ -57,7 +57,7 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
  #define PCIE_CORE_LINK_CTRL_STAT_REG                          0xd0
  #define     PCIE_CORE_LINK_L0S_ENTRY                          BIT(0)
  #define     PCIE_CORE_LINK_TRAINING                           BIT(5)
-@@ -299,7 +301,8 @@ static void advk_pcie_setup_hw(struct ad
+@@ -300,7 +302,8 @@ static void advk_pcie_setup_hw(struct ad
  
        /* Set PCIe Device Control and Status 1 PF0 register */
        reg = PCIE_CORE_DEV_CTRL_STATS_RELAX_ORDER_DISABLE |
@@ -67,7 +67,7 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
                PCIE_CORE_DEV_CTRL_STATS_SNOOP_DISABLE |
                (PCIE_CORE_DEV_CTRL_STATS_MAX_RD_REQ_SZ <<
                 PCIE_CORE_DEV_CTRL_STATS_MAX_RD_REQ_SIZE_SHIFT);
-@@ -922,6 +925,58 @@ out_release_res:
+@@ -968,6 +971,58 @@ out_release_res:
        return err;
  }
  
@@ -126,7 +126,7 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
  static int advk_pcie_probe(struct platform_device *pdev)
  {
        struct device *dev = &pdev->dev;
-@@ -996,6 +1051,9 @@ static int advk_pcie_probe(struct platfo
+@@ -1042,6 +1097,9 @@ static int advk_pcie_probe(struct platfo
        list_for_each_entry(child, &bus->children, node)
                pcie_bus_configure_settings(child);
  
index b5d694102407044f869d93e8a252d54b857ce1bc..33601237758cd439e026223f12ef7f741f067f1f 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
 
 --- a/drivers/pci/host/pci-aardvark.c
 +++ b/drivers/pci/host/pci-aardvark.c
-@@ -274,6 +274,8 @@ static void advk_pcie_set_ob_win(struct
+@@ -275,6 +275,8 @@ static void advk_pcie_set_ob_win(struct
  
  static void advk_pcie_setup_hw(struct advk_pcie *pcie)
  {
@@ -23,7 +23,7 @@ Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
        u32 reg;
        int i;
  
-@@ -313,10 +315,15 @@ static void advk_pcie_setup_hw(struct ad
+@@ -314,10 +316,15 @@ static void advk_pcie_setup_hw(struct ad
                PCIE_CORE_CTRL2_TD_ENABLE;
        advk_writel(pcie, reg, PCIE_CORE_CTRL2_REG);
  
index 313b9b564010d12bf3d720fc4dcf09e11decbef0..e20318ddf5f567053d6d44879e33f80da2d12ecd 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1936,6 +1936,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1937,6 +1937,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
          The command-line arguments provided by the boot loader will be
          appended to the the device tree bootargs property.
  
index a8b0f967f06ac1941ee71f146fbc7df0e8b6f8af..730439e03dfcbb866956e8623dbdc155034d4196 100644 (file)
@@ -15,7 +15,7 @@
        /* initialize internal qc */
  
        /* XXX: Tag 0 is used for drivers with legacy EH as some
-@@ -5136,6 +5144,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -5164,6 +5172,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
        if (unlikely(ap->pflags & ATA_PFLAG_FROZEN))
                return NULL;
  
@@ -25,7 +25,7 @@
        /* libsas case */
        if (ap->flags & ATA_FLAG_SAS_HOST) {
                tag = ata_sas_allocate_tag(ap);
-@@ -5181,6 +5192,8 @@ void ata_qc_free(struct ata_queued_cmd *
+@@ -5209,6 +5220,8 @@ void ata_qc_free(struct ata_queued_cmd *
                qc->tag = ATA_TAG_POISON;
                if (ap->flags & ATA_FLAG_SAS_HOST)
                        ata_sas_free_tag(tag, ap);
@@ -36,7 +36,7 @@
  
 --- a/include/linux/libata.h
 +++ b/include/linux/libata.h
-@@ -924,6 +924,8 @@ struct ata_port_operations {
+@@ -925,6 +925,8 @@ struct ata_port_operations {
        enum ata_completion_errors (*qc_prep)(struct ata_queued_cmd *qc);
        unsigned int (*qc_issue)(struct ata_queued_cmd *qc);
        bool (*qc_fill_rtf)(struct ata_queued_cmd *qc);
@@ -45,7 +45,7 @@
  
        /*
         * Configuration and exception handling
-@@ -1014,6 +1016,9 @@ struct ata_port_operations {
+@@ -1015,6 +1017,9 @@ struct ata_port_operations {
        void (*phy_reset)(struct ata_port *ap);
        void (*eng_timeout)(struct ata_port *ap);
  
index c777a0fffee14aa71debdee11c44b301c3e67151..0df9f99cd597ac36031589fb0cc8b906741710b7 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/phy/mdio_bus.c
 +++ b/drivers/net/phy/mdio_bus.c
-@@ -494,6 +494,55 @@ struct phy_device *mdiobus_scan(struct m
+@@ -501,6 +501,55 @@ struct phy_device *mdiobus_scan(struct m
  EXPORT_SYMBOL(mdiobus_scan);
  
  /**
@@ -75,7 +75,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
   * mdiobus_read_nested - Nested version of the mdiobus_read function
   * @bus: the mii_bus struct
   * @addr: the phy address
-@@ -513,11 +562,9 @@ int mdiobus_read_nested(struct mii_bus *
+@@ -520,11 +569,9 @@ int mdiobus_read_nested(struct mii_bus *
        BUG_ON(in_interrupt());
  
        mutex_lock_nested(&bus->mdio_lock, MDIO_MUTEX_NESTED);
@@ -88,7 +88,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        return retval;
  }
  EXPORT_SYMBOL(mdiobus_read_nested);
-@@ -539,11 +586,9 @@ int mdiobus_read(struct mii_bus *bus, in
+@@ -546,11 +593,9 @@ int mdiobus_read(struct mii_bus *bus, in
        BUG_ON(in_interrupt());
  
        mutex_lock(&bus->mdio_lock);
@@ -101,7 +101,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        return retval;
  }
  EXPORT_SYMBOL(mdiobus_read);
-@@ -569,11 +614,9 @@ int mdiobus_write_nested(struct mii_bus
+@@ -576,11 +621,9 @@ int mdiobus_write_nested(struct mii_bus
        BUG_ON(in_interrupt());
  
        mutex_lock_nested(&bus->mdio_lock, MDIO_MUTEX_NESTED);
@@ -114,7 +114,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        return err;
  }
  EXPORT_SYMBOL(mdiobus_write_nested);
-@@ -596,11 +639,9 @@ int mdiobus_write(struct mii_bus *bus, i
+@@ -603,11 +646,9 @@ int mdiobus_write(struct mii_bus *bus, i
        BUG_ON(in_interrupt());
  
        mutex_lock(&bus->mdio_lock);
@@ -129,7 +129,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  EXPORT_SYMBOL(mdiobus_write);
 --- a/include/linux/mdio.h
 +++ b/include/linux/mdio.h
-@@ -257,6 +257,9 @@ static inline u16 ethtool_adv_to_mmd_eee
+@@ -260,6 +260,9 @@ static inline u16 ethtool_adv_to_mmd_eee
        return reg;
  }