kernel: bump 4.9 to 4.9.215
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 9 Mar 2020 10:50:47 +0000 (11:50 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 9 Mar 2020 19:45:11 +0000 (20:45 +0100)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm2708/patches-4.9/950-0031-Add-dwc_otg-driver.patch
target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch
target/linux/layerscape/patches-4.9/810-iommu-support-layerscape.patch
target/linux/layerscape/patches-4.9/813-qe-support-layerscape.patch
target/linux/layerscape/patches-4.9/817-usb-support-layerscape.patch

index adbb93059987f80e2d3916315f952d1e221bae46..16a7ab31a2e44b704504ed18bdc7d4ff81e3d039 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .214
+LINUX_VERSION-4.9 = .215
 LINUX_VERSION-4.14 = .171
 
-LINUX_KERNEL_HASH-4.9.214 = b47f093dac7034c7c4722e80042c05e4ef53c14a4f28aa992117a127d2b1e483
+LINUX_KERNEL_HASH-4.9.215 = 236f2f47853700f22b9925cb17917d97ff7120fcc8110ec827c5a030a8129f48
 LINUX_KERNEL_HASH-4.14.171 = 4fe02489e4b4a187eccf0ef87df6100534c9d485e76d876b1fa247c7635332a0
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index f29bdf904b8f956632916adb2aa87ccfedee41bb..f909e88a108321007d5cbb4650443db9b3aaaa63 100644 (file)
@@ -696,7 +696,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
  }
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -5096,7 +5096,7 @@ static void port_event(struct usb_hub *h
+@@ -5091,7 +5091,7 @@ static void port_event(struct usb_hub *h
        if (portchange & USB_PORT_STAT_C_OVERCURRENT) {
                u16 status = 0, unused;
  
index 757e778cba492b34b974b80a2f4a3b2b3ba90786..393cbbabb61af71c695f02bb2a71950bf5016203 100644 (file)
@@ -637,7 +637,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                return received;
 --- a/drivers/net/ethernet/freescale/gianfar.c
 +++ b/drivers/net/ethernet/freescale/gianfar.c
-@@ -3197,7 +3197,7 @@ static int gfar_poll_rx_sq(struct napi_s
+@@ -3201,7 +3201,7 @@ static int gfar_poll_rx_sq(struct napi_s
  
        if (work_done < budget) {
                u32 imask;
@@ -646,7 +646,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                /* Clear the halt bit in RSTAT */
                gfar_write(&regs->rstat, gfargrp->rstat);
  
-@@ -3286,7 +3286,7 @@ static int gfar_poll_rx(struct napi_stru
+@@ -3290,7 +3290,7 @@ static int gfar_poll_rx(struct napi_stru
  
        if (!num_act_queues) {
                u32 imask;
@@ -1324,7 +1324,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        return rxd_done;
 --- a/drivers/net/wan/fsl_ucc_hdlc.c
 +++ b/drivers/net/wan/fsl_ucc_hdlc.c
-@@ -573,7 +573,7 @@ static int ucc_hdlc_poll(struct napi_str
+@@ -578,7 +578,7 @@ static int ucc_hdlc_poll(struct napi_str
        howmany += hdlc_rx_done(priv, budget - howmany);
  
        if (howmany < budget) {
index b2d282a751b40b1c643e47d7bd07f241b8f9fe5a..59cf0e7ad27f0017c0e6882c3f85df355203978d 100644 (file)
@@ -202,7 +202,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                dst[0] = cpu_to_le64(val);
                dst[1] = cpu_to_le64(STRTAB_STE_1_SHCFG_INCOMING
                         << STRTAB_STE_1_SHCFG_SHIFT);
-@@ -1114,10 +1127,7 @@ static void arm_smmu_write_strtab_ent(st
+@@ -1115,10 +1128,7 @@ static void arm_smmu_write_strtab_ent(st
  static void arm_smmu_init_bypass_stes(u64 *strtab, unsigned int nent)
  {
        unsigned int i;
@@ -214,7 +214,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
        for (i = 0; i < nent; ++i) {
                arm_smmu_write_strtab_ent(NULL, -1, strtab, &ste);
-@@ -1371,8 +1381,6 @@ static bool arm_smmu_capable(enum iommu_
+@@ -1372,8 +1382,6 @@ static bool arm_smmu_capable(enum iommu_
        switch (cap) {
        case IOMMU_CAP_CACHE_COHERENCY:
                return true;
@@ -223,7 +223,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        case IOMMU_CAP_NOEXEC:
                return true;
        default:
-@@ -1384,7 +1392,9 @@ static struct iommu_domain *arm_smmu_dom
+@@ -1385,7 +1393,9 @@ static struct iommu_domain *arm_smmu_dom
  {
        struct arm_smmu_domain *smmu_domain;
  
@@ -234,7 +234,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                return NULL;
  
        /*
-@@ -1515,6 +1525,11 @@ static int arm_smmu_domain_finalise(stru
+@@ -1516,6 +1526,11 @@ static int arm_smmu_domain_finalise(stru
        struct arm_smmu_domain *smmu_domain = to_smmu_domain(domain);
        struct arm_smmu_device *smmu = smmu_domain->smmu;
  
@@ -246,7 +246,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        /* Restrict the stage to what we can actually support */
        if (!(smmu->features & ARM_SMMU_FEAT_TRANS_S1))
                smmu_domain->stage = ARM_SMMU_DOMAIN_S2;
-@@ -1587,7 +1602,7 @@ static __le64 *arm_smmu_get_step_for_sid
+@@ -1588,7 +1603,7 @@ static __le64 *arm_smmu_get_step_for_sid
        return step;
  }
  
@@ -255,7 +255,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  {
        int i, j;
        struct arm_smmu_master_data *master = fwspec->iommu_priv;
-@@ -1606,17 +1621,14 @@ static int arm_smmu_install_ste_for_dev(
+@@ -1607,17 +1622,14 @@ static int arm_smmu_install_ste_for_dev(
  
                arm_smmu_write_strtab_ent(smmu, sid, step, &master->ste);
        }
@@ -275,7 +275,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  }
  
  static int arm_smmu_attach_dev(struct iommu_domain *domain, struct device *dev)
-@@ -1635,7 +1647,7 @@ static int arm_smmu_attach_dev(struct io
+@@ -1636,7 +1648,7 @@ static int arm_smmu_attach_dev(struct io
        ste = &master->ste;
  
        /* Already attached to a different domain? */
@@ -284,7 +284,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                arm_smmu_detach_dev(dev);
  
        mutex_lock(&smmu_domain->init_mutex);
-@@ -1656,10 +1668,12 @@ static int arm_smmu_attach_dev(struct io
+@@ -1657,10 +1669,12 @@ static int arm_smmu_attach_dev(struct io
                goto out_unlock;
        }
  
@@ -300,7 +300,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                ste->s1_cfg = &smmu_domain->s1_cfg;
                ste->s2_cfg = NULL;
                arm_smmu_write_ctx_desc(smmu, ste->s1_cfg);
-@@ -1668,10 +1682,7 @@ static int arm_smmu_attach_dev(struct io
+@@ -1669,10 +1683,7 @@ static int arm_smmu_attach_dev(struct io
                ste->s2_cfg = &smmu_domain->s2_cfg;
        }
  
@@ -312,7 +312,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  out_unlock:
        mutex_unlock(&smmu_domain->init_mutex);
        return ret;
-@@ -1719,6 +1730,9 @@ arm_smmu_iova_to_phys(struct iommu_domai
+@@ -1720,6 +1731,9 @@ arm_smmu_iova_to_phys(struct iommu_domai
        struct arm_smmu_domain *smmu_domain = to_smmu_domain(domain);
        struct io_pgtable_ops *ops = smmu_domain->pgtbl_ops;
  
@@ -322,7 +322,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        if (!ops)
                return 0;
  
-@@ -1817,7 +1831,7 @@ static void arm_smmu_remove_device(struc
+@@ -1818,7 +1832,7 @@ static void arm_smmu_remove_device(struc
                return;
  
        master = fwspec->iommu_priv;
@@ -331,7 +331,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                arm_smmu_detach_dev(dev);
        iommu_group_remove_device(dev);
        kfree(master);
-@@ -1846,6 +1860,9 @@ static int arm_smmu_domain_get_attr(stru
+@@ -1847,6 +1861,9 @@ static int arm_smmu_domain_get_attr(stru
  {
        struct arm_smmu_domain *smmu_domain = to_smmu_domain(domain);
  
@@ -341,7 +341,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        switch (attr) {
        case DOMAIN_ATTR_NESTING:
                *(int *)data = (smmu_domain->stage == ARM_SMMU_DOMAIN_NESTED);
-@@ -1861,6 +1878,9 @@ static int arm_smmu_domain_set_attr(stru
+@@ -1862,6 +1879,9 @@ static int arm_smmu_domain_set_attr(stru
        int ret = 0;
        struct arm_smmu_domain *smmu_domain = to_smmu_domain(domain);
  
@@ -351,7 +351,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        mutex_lock(&smmu_domain->init_mutex);
  
        switch (attr) {
-@@ -1890,6 +1910,31 @@ static int arm_smmu_of_xlate(struct devi
+@@ -1891,6 +1911,31 @@ static int arm_smmu_of_xlate(struct devi
        return iommu_fwspec_add_ids(dev, args->args, 1);
  }
  
@@ -383,7 +383,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  static struct iommu_ops arm_smmu_ops = {
        .capable                = arm_smmu_capable,
        .domain_alloc           = arm_smmu_domain_alloc,
-@@ -1905,6 +1950,8 @@ static struct iommu_ops arm_smmu_ops = {
+@@ -1906,6 +1951,8 @@ static struct iommu_ops arm_smmu_ops = {
        .domain_get_attr        = arm_smmu_domain_get_attr,
        .domain_set_attr        = arm_smmu_domain_set_attr,
        .of_xlate               = arm_smmu_of_xlate,
index 1dfa46e839579c136fdb8652aafa1dec0d49d7a8..270a13640adde8f79e0a7b90379aba694784e515 100644 (file)
@@ -1151,7 +1151,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
 +IRQCHIP_DECLARE(qeic, "fsl,qe-ic", init_qe_ic);
 --- a/drivers/net/wan/fsl_ucc_hdlc.c
 +++ b/drivers/net/wan/fsl_ucc_hdlc.c
-@@ -381,8 +381,8 @@ static netdev_tx_t ucc_hdlc_tx(struct sk
+@@ -386,8 +386,8 @@ static netdev_tx_t ucc_hdlc_tx(struct sk
        /* set bd status and length */
        bd_status = (bd_status & T_W_S) | T_R_S | T_I_S | T_L_S | T_TC_S;
  
@@ -1161,7 +1161,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
        /* Move to next BD in the ring */
        if (!(bd_status & T_W_S))
-@@ -457,7 +457,7 @@ static int hdlc_rx_done(struct ucc_hdlc_
+@@ -462,7 +462,7 @@ static int hdlc_rx_done(struct ucc_hdlc_
        struct sk_buff *skb = NULL;
        hdlc_device *hdlc = dev_to_hdlc(dev);
        struct qe_bd *bd;
index 525170a9c8f27054882302bb1445eb9d912e8583..11b759e700eb368857bf35c8c2067b6e52e105af 100644 (file)
@@ -156,7 +156,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        int ret;
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -4455,6 +4455,14 @@ hub_port_init(struct usb_hub *hub, struc
+@@ -4450,6 +4450,14 @@ hub_port_init(struct usb_hub *hub, struc
        else
                speed = usb_speed_string(udev->speed);