openssl: bump to 1.0.2t, Makefile updates
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Tue, 17 Sep 2019 19:01:45 +0000 (16:01 -0300)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 20 Sep 2019 18:50:35 +0000 (20:50 +0200)
This version fixes 3 low-severity vulnerabilities:

- CVE-2019-1547: ECDSA remote timing attack
- CVE-2019-1549: Fork Protection
- CVE-2019-1563: Padding Oracle in PKCS7_dataDecode and
                 CMS_decrypt_set1_pkey

Patches were refreshed, PKG_SOURCE_URL was updated to match
openwrt-18.06, and Eneas U de Queiroz added as maintainer.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
package/libs/openssl/Makefile
package/libs/openssl/patches/150-no_engines.patch

index 60357604b1ff474bfef8a4a65d71a7f3a13c90d3..3f8907cf17b491bb43f4f33f00314425a3ddc472 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
 PKG_BASE:=1.0.2
-PKG_BUGFIX:=s
+PKG_BUGFIX:=t
 PKG_VERSION:=$(PKG_BASE)$(PKG_BUGFIX)
 PKG_RELEASE:=1
 PKG_USE_MIPS16:=0
@@ -18,15 +18,17 @@ PKG_BUILD_PARALLEL:=0
 
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.openssl.org/source/ \
-       ftp://ftp.openssl.org/source/ \
-       http://www.openssl.org/source/old/$(PKG_BASE)/ \
-       ftp://ftp.funet.fi/pub/crypt/mirrors/ftp.openssl.org/source \
-       ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
-PKG_HASH:=cabd5c9492825ce5bd23f3c3aeed6a97f8142f606d893df216411f07d1abab96
+PKG_SOURCE_URL:= \
+       http://ftp.fi.muni.cz/pub/openssl/source/ \
+       http://ftp.linux.hr/pub/openssl/source/ \
+       http://gd.tuwien.ac.at/infosys/security/openssl/source/ \
+       http://www.openssl.org/source/ \
+       http://www.openssl.org/source/old/$(PKG_BASE)/
+PKG_HASH:=14cb464efe7ac6b54799b34456bd69558a749a4931ecfd9cf9f71d7881cac7bc
 
 PKG_LICENSE:=OpenSSL
 PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Eneas U de Queiroz <cotequeiroz@gmail.com>
 PKG_CONFIG_DEPENDS:= \
        CONFIG_OPENSSL_ENGINE_CRYPTO \
        CONFIG_OPENSSL_ENGINE_DIGEST \
index a518a00496605edef7795f40feeb6aa7c4f41dfc..314075a9109b1aff92629257952593b3babac6a6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Configure
 +++ b/Configure
-@@ -2144,6 +2144,11 @@ EOF
+@@ -2145,6 +2145,11 @@ EOF
        close(OUT);
    }