build: ensure that dash isn't prepended twice to abi version suffix
authorJo-Philipp Wich <jo@mein.io>
Tue, 15 Jun 2021 07:54:45 +0000 (09:54 +0200)
committerJo-Philipp Wich <jo@mein.io>
Tue, 15 Jun 2021 07:58:33 +0000 (09:58 +0200)
The ABIV_$(pkgname) variable already is formatted so return it as-is from
the GetABISuffix macro and only filter through FormatABISuffix if we read
the raw ABI version value from a version stamp file.

This ensures that binary intra-package dependencies on ABI versioned
libraries are properly formatted.

Ref: https://github.com/openwrt/packages/issues/15871
Fixes: f6a03bff5b ("build: prepend ABI suffixes with a dash if package name ends with digit")
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
include/feeds.mk

index e499ac2684a78deb3935fad56174e34b7a131b29..632fecb4a3aaece1cada2b8d2ae089c85dc2d1a6 100644 (file)
@@ -43,7 +43,7 @@ endef
 
 # 1: package name
 define GetABISuffix
-$(call FormatABISuffix,$(1),$(if $(ABIV_$(1)),$(ABIV_$(1)),$(foreach v,$(wildcard $(STAGING_DIR)/pkginfo/$(1).version),$(shell cat $(v)))))
+$(if $(ABIV_$(1)),$(ABIV_$(1)),$(call FormatABISuffix,$(1),$(foreach v,$(wildcard $(STAGING_DIR)/pkginfo/$(1).version),$(shell cat $(v)))))
 endef
 
 # 1: package name