uboot-ar71xx: fix default selection for NBG460N/550N/550NH
authorFelix Fietkau <nbd@nbd.name>
Tue, 2 Aug 2016 11:49:27 +0000 (13:49 +0200)
committerFelix Fietkau <nbd@nbd.name>
Tue, 2 Aug 2016 11:50:43 +0000 (13:50 +0200)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/boot/uboot-ar71xx/Makefile

index 7c4bb6ce8a0f428d9b749bce3edb47318c4b8149..c80d6eb448bd8ec041d970ed770ea45811f37d5f 100644 (file)
@@ -33,6 +33,7 @@ endef
 
 define uboot/nbg460n_550n_550nh
   TITLE:=U-boot for the NBG460N/550N/550NH routers
+  DEFAULT:=y if (TARGET_ar71xx_generic_DEVICE_NBG_460N_550N_550NH || TARGET_DEVICE_ar71xx_generic_DEVICE_NBG_460N_550N_550NH || TARGET_ar71xx_generic_Default)
 endef
 
 UBOOTS:=nbg460n_550n_550nh
@@ -44,7 +45,6 @@ define Package/uboot-ar71xx-$(1)
   TITLE:=$(2)
   DEPENDS:=@TARGET_ar71xx_generic
   URL:=http://www.denx.de/wiki/U-Boot
-  DEFAULT:=y if (TARGET_ar71xx_generic_NBG_460N_550N_550NH || TARGET_ar71xx_generic_Default || CONFIG_TARGET_ar71xx_generic_Minimal)
   VARIANT:=$(1)
 endef
 endef