sunxi: modules: remove useless AddDepends/rtc
authorChukun Pan <amadeus@jmu.edu.cn>
Thu, 1 Sep 2022 15:18:19 +0000 (23:18 +0800)
committerChristian Lamparter <chunkeey@gmail.com>
Mon, 12 Dec 2022 08:06:17 +0000 (09:06 +0100)
AddDepends/rtc has been removed in commit 3da7fe6, same here.
Fixes: 3da7fe6 ("kernel: remove useless AddDepends/rtc abstraction")
Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn>
(RTC_SUPPORT - though this is implied by the TARGET_sunxi)
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/sunxi/modules.mk

index 99f4db760446964bce5265c8d7cd0a942b8bbec0..0c8ed83d0d8972c0dac60932d3a15030a7a8d5aa 100644 (file)
@@ -5,8 +5,7 @@
 define KernelPackage/rtc-sunxi
     SUBMENU:=$(OTHER_MENU)
     TITLE:=Sunxi SoC built-in RTC support
-    DEPENDS:=@TARGET_sunxi
-    $(call AddDepends/rtc)
+    DEPENDS:=@(TARGET_sunxi&&RTC_SUPPORT)
     KCONFIG:= \
        CONFIG_RTC_DRV_SUNXI \
        CONFIG_RTC_CLASS=y
@@ -23,8 +22,7 @@ $(eval $(call KernelPackage,rtc-sunxi))
 define KernelPackage/sunxi-ir
     SUBMENU:=$(OTHER_MENU)
     TITLE:=Sunxi SoC built-in IR support (A20)
-    DEPENDS:=@TARGET_sunxi +kmod-input-core
-    $(call AddDepends/rtc)
+    DEPENDS:=@(TARGET_sunxi&&RTC_SUPPORT) +kmod-input-core
     KCONFIG:= \
        CONFIG_MEDIA_SUPPORT=y \
        CONFIG_MEDIA_RC_SUPPORT=y \