kernel: fix Aquantia AQtion Atlantic module dependencies
authorDaniel Golle <daniel@makrotopia.org>
Sat, 10 Sep 2022 17:21:39 +0000 (18:21 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Sat, 10 Sep 2022 17:23:14 +0000 (18:23 +0100)
The buildbot revealed that
Package kmod-atlantic is missing dependencies for the following libraries:
hwmon.ko
macsec.ko
make[2]: *** [modules/netdevices.mk:1474: /builder/shared-workdir/build/bin/targets/mediatek/mt7629/packages/kmod-atlantic_5.15.67-1_arm_cortex-a7.ipk] Error 1
make[2]: Leaving directory '/builder/shared-workdir/build/package/kernel/linux'
time: package/kernel/linux/compile#43.51#17.03#415.37
    ERROR: package/kernel/linux failed to build.
make[1]: *** [package/Makefile:116: package/kernel/linux/compile] Error 1
make[1]: *** Waiting for unfinished jobs....

Add those missing dependencies to fix the build.

Fixes: d02e887d7c ("kernel: add Aquantia AQtion Atlantic 10Gbps Ethernet")
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/kernel/linux/modules/netdevices.mk

index f048b01d8b752cac22ba46c28d4aa73560b4c8ac..394180902d6a98a9fcfab64fe4f41e5d831e4908 100644 (file)
@@ -1461,7 +1461,7 @@ $(eval $(call KernelPackage,mhi-wwan-mbim))
 define KernelPackage/atlantic
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=Aquantia AQtion 10Gbps Ethernet NIC
-  DEPENDS:=@PCI_SUPPORT +kmod-ptp
+  DEPENDS:=@PCI_SUPPORT +kmod-ptp +kmod-hwmon-core +kmod-macsec
   KCONFIG:=CONFIG_AQTION
   FILES:=$(LINUX_DIR)/drivers/net/ethernet/aquantia/atlantic/atlantic.ko
   AUTOLOAD:=$(call AutoProbe,atlantic)