kernel: refresh patches
authorDaniel Golle <daniel@makrotopia.org>
Wed, 7 Sep 2022 02:54:34 +0000 (03:54 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 7 Sep 2022 03:21:41 +0000 (04:21 +0100)
The introduction of the new Airoha target has left the tree in an
unfresh state. Refresh patches to improve that situation.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/generic/pending-5.15/487-mtd-spinand-Add-support-for-Etron-EM73D044VCx.patch
target/linux/generic/pending-5.15/773-net-sfp-add-support-for-HALNy-GPON-SFP.patch
target/linux/mediatek/patches-5.15/120-08-v5.18-mtd-spinand-Delay-a-little-bit-the-dirmap-creation.patch
target/linux/mediatek/patches-5.15/120-09-v5.18-mtd-spinand-Create-direct-mapping-descriptors-for-EC.patch
target/linux/mediatek/patches-5.15/330-snand-mtk-bmt-support.patch

index a48e02fc083bca74acbed67f10b4308293368106..c32e15d0c642d7bfd8d9ab0bf7d9ebeb8f13d679 100644 (file)
@@ -1,5 +1,3 @@
-diff --git a/drivers/mtd/nand/spi/Makefile b/drivers/mtd/nand/spi/Makefile
-index 9c64d9fc..5f99ea72 100644
 --- a/drivers/mtd/nand/spi/Makefile
 +++ b/drivers/mtd/nand/spi/Makefile
 @@ -1,3 +1,3 @@
@@ -7,21 +5,16 @@ index 9c64d9fc..5f99ea72 100644
 -spinand-objs := core.o esmt.o gigadevice.o macronix.o micron.o paragon.o toshiba.o winbond.o xtx.o
 +spinand-objs := core.o esmt.o etron.o gigadevice.o macronix.o micron.o paragon.o toshiba.o winbond.o xtx.o
  obj-$(CONFIG_MTD_SPI_NAND) += spinand.o
-diff --git a/drivers/mtd/nand/spi/core.c b/drivers/mtd/nand/spi/core.c
-index 9839ee44..9ab44217 100644
 --- a/drivers/mtd/nand/spi/core.c
 +++ b/drivers/mtd/nand/spi/core.c
-@@ -898,6 +898,7 @@ static const struct nand_ops spinand_ops = {
+@@ -898,6 +898,7 @@ static const struct nand_ops spinand_ops
  static const struct spinand_manufacturer *spinand_manufacturers[] = {
-       &esmt_c8_spinand_manufacturer,
-       &gigadevice_spinand_manufacturer,
+       &esmt_c8_spinand_manufacturer,
+       &gigadevice_spinand_manufacturer,
 +      &etron_spinand_manufacturer,
-       &macronix_spinand_manufacturer,
-       &micron_spinand_manufacturer,
-       &paragon_spinand_manufacturer,
-diff --git a/drivers/mtd/nand/spi/etron.c b/drivers/mtd/nand/spi/etron.c
-new file mode 100644
-index 00000000..653092be
+       &macronix_spinand_manufacturer,
+       &micron_spinand_manufacturer,
+       &paragon_spinand_manufacturer,
 --- /dev/null
 +++ b/drivers/mtd/nand/spi/etron.c
 @@ -0,0 +1,98 @@
@@ -123,12 +116,10 @@ index 00000000..653092be
 +      .nchips = ARRAY_SIZE(etron_spinand_table),
 +      .ops = &etron_spinand_manuf_ops,
 +};
-diff --git a/include/linux/mtd/spinand.h b/include/linux/mtd/spinand.h
-index 2066962d..11d38d2f 100644
 --- a/include/linux/mtd/spinand.h
 +++ b/include/linux/mtd/spinand.h
 @@ -261,6 +261,7 @@ struct spinand_manufacturer {
-
  /* SPI NAND manufacturers */
  extern const struct spinand_manufacturer esmt_c8_spinand_manufacturer;
 +extern const struct spinand_manufacturer etron_spinand_manufacturer;
index 9ec47812734834064cac56ccc80eb8d4942fc86a..85c1d5b2031debe5320c053350c8509854d54265 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Russell King (Oracle) <rmk+kernel@armlinux.org.uk>
 +      if (bus->sfp_quirk && bus->sfp_quirk->modes)
                bus->sfp_quirk->modes(id, modes);
  
-       bitmap_or(support, support, modes, __ETHTOOL_LINK_MODE_MASK_NBITS);
+       linkmode_or(support, support, modes);
 --- a/drivers/net/phy/sfp.c
 +++ b/drivers/net/phy/sfp.c
 @@ -320,6 +320,23 @@ static void sfp_fixup_ignore_tx_fault(st
index 192b1221edd751b9c9c2a5a58a27c37c97b3cba0..0f69b30e947204156c64fd8ab881ee4b8243bf55 100644 (file)
@@ -18,7 +18,7 @@ Link: https://lore.kernel.org/linux-mtd/20220127091808.1043392-8-miquel.raynal@b
 
 --- a/drivers/mtd/nand/spi/core.c
 +++ b/drivers/mtd/nand/spi/core.c
-@@ -1210,14 +1210,6 @@ static int spinand_init(struct spinand_d
+@@ -1211,14 +1211,6 @@ static int spinand_init(struct spinand_d
        if (ret)
                goto err_free_bufs;
  
@@ -33,7 +33,7 @@ Link: https://lore.kernel.org/linux-mtd/20220127091808.1043392-8-miquel.raynal@b
        ret = nanddev_init(nand, &spinand_ops, THIS_MODULE);
        if (ret)
                goto err_manuf_cleanup;
-@@ -1252,6 +1244,14 @@ static int spinand_init(struct spinand_d
+@@ -1253,6 +1245,14 @@ static int spinand_init(struct spinand_d
        mtd->ecc_strength = nanddev_get_ecc_conf(nand)->strength;
        mtd->ecc_step_size = nanddev_get_ecc_conf(nand)->step_size;
  
index 86df0270d8211c9c60eb5c3dace0ed1904d70df7..1188872bd787316056b7040b86193970c84830f9 100644 (file)
@@ -87,7 +87,7 @@ Link: https://lore.kernel.org/linux-mtd/20220127091808.1043392-9-miquel.raynal@b
  
 --- a/include/linux/mtd/spinand.h
 +++ b/include/linux/mtd/spinand.h
-@@ -391,6 +391,8 @@ struct spinand_info {
+@@ -392,6 +392,8 @@ struct spinand_info {
  struct spinand_dirmap {
        struct spi_mem_dirmap_desc *wdesc;
        struct spi_mem_dirmap_desc *rdesc;
index 48bfb0d358153a85166e22f0d7200051eb846ed9..cd1745dd7a223feccf31dc1a79c3725957c4cc8b 100644 (file)
@@ -8,7 +8,7 @@
  
  static int spinand_read_reg_op(struct spinand_device *spinand, u8 reg, u8 *val)
  {
-@@ -1332,6 +1333,7 @@ static int spinand_probe(struct spi_mem
+@@ -1333,6 +1334,7 @@ static int spinand_probe(struct spi_mem
        if (ret)
                return ret;
  
@@ -16,7 +16,7 @@
        ret = mtd_device_register(mtd, NULL, 0);
        if (ret)
                goto err_spinand_cleanup;
-@@ -1339,6 +1341,7 @@ static int spinand_probe(struct spi_mem
+@@ -1340,6 +1342,7 @@ static int spinand_probe(struct spi_mem
        return 0;
  
  err_spinand_cleanup:
@@ -24,7 +24,7 @@
        spinand_cleanup(spinand);
  
        return ret;
-@@ -1357,6 +1360,7 @@ static int spinand_remove(struct spi_mem
+@@ -1358,6 +1361,7 @@ static int spinand_remove(struct spi_mem
        if (ret)
                return ret;