build: remove image specific checksum code
authorJo-Philipp Wich <jo@mein.io>
Tue, 26 Jul 2016 13:08:19 +0000 (15:08 +0200)
committerJo-Philipp Wich <jo@mein.io>
Mon, 1 Aug 2016 16:11:26 +0000 (18:11 +0200)
Now that we globally calculate sha256sums over the bin/ directory we can remove
the target image specific checksum handling.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
include/image.mk

index 415618d393dadd4227b6d046913a11b3e59d7ef5..91862c42a55c2b39369b53660e413bc1a1b65c88 100644 (file)
@@ -265,12 +265,6 @@ define Image/mkfs/prepare
 endef
 
 
-define Image/Checksum
-       ( cd ${BIN_DIR} ; \
-               $(FIND) -maxdepth 1 -type f \! -name 'md5sums'  -printf "%P\n" | sort | xargs $1 > $2 \
-       )
-endef
-
 ifdef CONFIG_TARGET_ROOTFS_TARGZ
   define Image/Build/targz
        $(TAR) -cp --numeric-owner --owner=0 --group=0 --sort=name \
@@ -569,7 +563,5 @@ define BuildImage
        $(MAKE) legacy-images
 
   install: install-images
-       $(call Image/Checksum,md5sum --binary,md5sums)
-       $(call Image/Checksum,openssl dgst -sha256,sha256sums)
 
 endef