ath79: rename references of UniFi to UniFi AP
authorJan-Niklas Burfeind <git@aiyionpri.me>
Mon, 11 Jul 2022 20:42:59 +0000 (22:42 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 6 Aug 2022 18:15:30 +0000 (20:15 +0200)
extract the compatible and model to make room for other variants

follow-up of
commit dc23df8a8ca7 ("ath79: change Ubiquiti UniFi AP model name to include "AP"")

Signed-off-by: Jan-Niklas Burfeind <git@aiyionpri.me>
target/linux/ath79/dts/ar7241_ubnt_unifi-ap.dts [new file with mode: 0644]
target/linux/ath79/dts/ar7241_ubnt_unifi-ap.dtsi [new file with mode: 0644]
target/linux/ath79/dts/ar7241_ubnt_unifi.dts [deleted file]
target/linux/ath79/image/generic-ubnt.mk

diff --git a/target/linux/ath79/dts/ar7241_ubnt_unifi-ap.dts b/target/linux/ath79/dts/ar7241_ubnt_unifi-ap.dts
new file mode 100644 (file)
index 0000000..e9f57c0
--- /dev/null
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar7241_ubnt_unifi-ap.dtsi"
+
+/ {
+       compatible = "ubnt,unifi", "qca,ar7241";
+       model = "Ubiquiti UniFi AP";
+};
diff --git a/target/linux/ath79/dts/ar7241_ubnt_unifi-ap.dtsi b/target/linux/ath79/dts/ar7241_ubnt_unifi-ap.dtsi
new file mode 100644 (file)
index 0000000..c70a1c0
--- /dev/null
@@ -0,0 +1,97 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar7241_ubnt_unifi.dtsi"
+
+/ {
+       aliases {
+               led-boot = &led_dome_green;
+               led-failsafe = &led_dome_green;
+               led-running = &led_dome_green;
+               led-upgrade = &led_dome_green;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_dome_green: dome_green {
+                       label = "green:dome";
+                       gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
+               };
+
+               dome_orange {
+                       label = "orange:dome";
+                       gpios = <&gpio 1 GPIO_ACTIVE_HIGH>;
+               };
+       };
+};
+
+&spi {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x040000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "u-boot-env";
+                               reg = <0x040000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@50000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x050000 0x750000>;
+                       };
+
+                       partition@7a0000 {
+                               label = "board_config";
+                               reg = <0x7a0000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@7b0000 {
+                               label = "cfg";
+                               reg = <0x7b0000 0x040000>;
+                               read-only;
+                       };
+
+                       art: partition@7f0000 {
+                               label = "art";
+                               reg = <0x7f0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&eth0 {
+       nvmem-cells = <&macaddr_art_0>;
+       nvmem-cell-names = "mac-address";
+};
+
+&eth1 {
+       compatible = "syscon", "simple-mfd";
+};
+
+&art {
+       compatible = "nvmem-cells";
+       #address-cells = <1>;
+       #size-cells = <1>;
+
+       macaddr_art_0: macaddr@0 {
+               reg = <0x0 0x6>;
+       };
+};
diff --git a/target/linux/ath79/dts/ar7241_ubnt_unifi.dts b/target/linux/ath79/dts/ar7241_ubnt_unifi.dts
deleted file mode 100644 (file)
index 3c50e89..0000000
+++ /dev/null
@@ -1,100 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-
-#include "ar7241_ubnt_unifi.dtsi"
-
-/ {
-       compatible = "ubnt,unifi", "qca,ar7241";
-       model = "Ubiquiti UniFi AP";
-
-       aliases {
-               led-boot = &led_dome_green;
-               led-failsafe = &led_dome_green;
-               led-running = &led_dome_green;
-               led-upgrade = &led_dome_green;
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               led_dome_green: dome_green {
-                       label = "green:dome";
-                       gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
-               };
-
-               dome_orange {
-                       label = "orange:dome";
-                       gpios = <&gpio 1 GPIO_ACTIVE_HIGH>;
-               };
-       };
-};
-
-&spi {
-       status = "okay";
-
-       flash@0 {
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <25000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "u-boot";
-                               reg = <0x000000 0x040000>;
-                               read-only;
-                       };
-
-                       partition@40000 {
-                               label = "u-boot-env";
-                               reg = <0x040000 0x010000>;
-                               read-only;
-                       };
-
-                       partition@50000 {
-                               compatible = "denx,uimage";
-                               label = "firmware";
-                               reg = <0x050000 0x750000>;
-                       };
-
-                       partition@7a0000 {
-                               label = "board_config";
-                               reg = <0x7a0000 0x010000>;
-                               read-only;
-                       };
-
-                       partition@7b0000 {
-                               label = "cfg";
-                               reg = <0x7b0000 0x040000>;
-                               read-only;
-                       };
-
-                       art: partition@7f0000 {
-                               label = "art";
-                               reg = <0x7f0000 0x010000>;
-                               read-only;
-                       };
-               };
-       };
-};
-
-&eth0 {
-       nvmem-cells = <&macaddr_art_0>;
-       nvmem-cell-names = "mac-address";
-};
-
-&eth1 {
-       compatible = "syscon", "simple-mfd";
-};
-
-&art {
-       compatible = "nvmem-cells";
-       #address-cells = <1>;
-       #size-cells = <1>;
-
-       macaddr_art_0: macaddr@0 {
-               reg = <0x0 0x6>;
-       };
-};
index 69f7a948631609761fa7e74058dd183995a57cc2..e6a6de48f0567659580fe49b7306132db639cc66 100644 (file)
@@ -210,12 +210,12 @@ define Device/ubnt_routerstation-pro
 endef
 TARGET_DEVICES += ubnt_routerstation-pro
 
-define Device/ubnt_unifi
+define Device/ubnt_unifi-ap
   $(Device/ubnt-bz)
   DEVICE_MODEL := UniFi AP
-  SUPPORTED_DEVICES += unifi
+  SUPPORTED_DEVICES += unifi ubnt,unifi
 endef
-TARGET_DEVICES += ubnt_unifi
+TARGET_DEVICES += ubnt_unifi-ap
 
 define Device/ubnt_unifiac
   DEVICE_VENDOR := Ubiquiti