ucode: add temporary fix for integer formatting on 32bit systems
authorJo-Philipp Wich <jo@mein.io>
Sat, 22 Jan 2022 23:51:11 +0000 (00:51 +0100)
committerJo-Philipp Wich <jo@mein.io>
Sat, 22 Jan 2022 23:57:58 +0000 (00:57 +0100)
The ucode VM always passes 64bit integer values to sprintf implementation
while the `%d` format expects 32bit integers on 32bit platforms, leading
to incorrect formatting results.

Temporarily solve the issue by casting the numeric argument to int until
a more thorough fix arrives with the next update.

Fixes: FS#4234
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/utils/ucode/Makefile
package/utils/ucode/patches/100-fix-int-format-on-32bit-system.patch [new file with mode: 0644]

index 2c11fe05bebd51279aa08dbb1cd7a60897ac6c26..beafb94bb481cfd0cb5d4ba2e6b21c053d5fa671 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ucode
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=https://github.com/jow-/ucode.git
diff --git a/package/utils/ucode/patches/100-fix-int-format-on-32bit-system.patch b/package/utils/ucode/patches/100-fix-int-format-on-32bit-system.patch
new file mode 100644 (file)
index 0000000..c557d0c
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/lib.c
++++ b/lib.c
+@@ -1438,7 +1438,7 @@ uc_printf_common(uc_vm_t *vm, size_t nar
+                       switch (t) {
+                       case UC_INTEGER:
+-                              ucv_stringbuf_printf(buf, sfmt, arg.n);
++                              ucv_stringbuf_printf(buf, sfmt, (int)arg.n);
+                               break;
+                       case UC_DOUBLE: